[FE9] Character Editor and Randomizer [v1.3.2]

That is usually when there is a pretty big thing wrong, like a file failing to compress. It often happens from having files open in another program while using the editor, or building the game with the editor open.

I tried randomizing each field in the european version, also I try to close every other program while I do each step and it keeps happening, thanks for your time

I can randomize and play the european version just fine on the latest version, so it’s not a general issue. Do you still get the issue if you just open the root in the editor and then Save & Quit without making edits? If yes, does it happen even if you didn’t use the editor at all and just rebuild the vanilla game?

Made an account just to post here. This is some great stuff.
Unfortunately, I’m running into an issue where the game crashes after the Intelligent Systems logo upon randomizing. The editor seems to work just fine for me, though. If there’s any solutions you could suggest, I’d sure appreciate it.

1 Like

Are you using exactly stable release 5.0 of Dolphin? No extra numbers.
That error usually happens when using different versions of Dolphin

Ah, yeah I’m using the latest version of Dolphin.
I installed the stable 5.0 version of Dolphin, but now I’m running into another issue… I’m getting a message “Unknown entry type 6 in SYSCONF (IPL.TID@1818)!”
After closing that message, the Dolphin program opens up along with another warning: “Trying to read from invalid SYSCONF.” Trying to close this just results in it reopening endlessly, making Dolphin unusable.
I imagine this is getting out of your area of expertise, so I won’t try to have you troubleshoot that. Thanks anyway, though.

i have the usa ISO plus GC-tool but i cant extract the root, GC-tool doesn aknowledge the iso i have
i can play the game on dolphin but cant randomized it cause i have no root

What is the problem more specifically?
Is it that you can’t find the iso? Then try setting it to Files of type: All Files.
If you can open it but extracting causes an error, try if you can find a different iso and see if it still happens.

i manage to root it , randomized it but now i have a black screen before the main menu cant do nothing :frowning:

That is usually caused by playing on a version of Dolphin that is not specifically stable release 5.0, the one with no extra numbers.

seem working now thx!

ive got an iso but I not sure how to get the zmap

I’ve gotten the root folder but it has thrown up this error. What should I do?

Does it do the same if you try again?
Does the file path to where your root folder is located have weird characters in it?
Do you have anything in the root folder open in another program?

I’ll check what kind of problems i gave the overly broad error message “Failed decompression”.

I’ve tried it a few more times and renamed he folder its in to only have letters and spaces and it isn’t open in anything else but I got the same error. Have you had any luck finding any reasons for the issue

Have you found a reason for the error yet?

So, this new option: “Ch 1 house content”. What exactly is this?

Changes the item in the first house in Ch 1. It is there because there are too few lances in the earlygame.

Do you know why there would be an error message of “Failed decompression”

I’m sorry i never came back to you, i seriously burned out on this project for a while there.

The error seems to come up with a dispos file that doesn’t look like the program expects it to. Is it the japanese version you have? Either way, maybe a different ISO (US or PAL, the other one than you currently have) could work but I’m not hopeful. I can’t come up with many ways the program could fail there without being a problem everyone has, since it is at a point past the normal compression checks that it suddenly runs out of file to read.