[FE9] Character Editor and Randomizer [v1.2]


#108

As far as i can tell it was applying the old growth increases in reverse, could you try the version i just uploaded?

Edit: Specifically version 1.1.2, if you were quick you got 1.1.1, which was me messing up and putting out 1.1 again with a new name.


#109

Alright, the enemy growths are finally working now. Thanks for addressing.


#110

Ok, now here is the system.cmp .
https://drive.google.com/file/d/1H5r5i5QrlFZ3Pfrm5UpZR-zoWYarz66p/view?usp=sharing


#111

So I just completed a full randomized playthrough on hard mode with 35% enemy growths.

-35% actually gave the game a fair bit of challenge. The chapter where Marcia was recruited was insanely difficult and required creative chokepointing to not only fight through the strong enemies, but to save the houses and recruit Marcia without her getting attacked by the approaching enemies from the south. Forging weapons was an absolute must, which was the first time I felt like I actually needed to use forges. Tanith’s Reinforce was also a necessity for distracting enemies, draining enemy tomes/staves/ballistae, and getting the heat off my army while we focus on the objective.

-Sothe has shown that he was a great unit just in a bad class. As a Fire Mage, he capped almost every stat (besides Defense) and became one of my MVPs despite a rough start training him up. However, even after being promoted, he can’t use an Occult scroll. Funny enough, out of all my units, he was one of the few with an actual Luck growth, nearly capping it while almost everyone else ended up with low teens.

-Besides Sothe, my MVPs were Paladin Soren, Swordmaster Ike, Raven Stefan, and Dragon Titania (even though she was benched during the second half of the game). Stefan and Soren carried the army like bags of groceries.

-Skills seem to be a little weird. During my first randomizer attempt, on Chapter 10, Fighter Keiran seemed to have the thief’s ability to open doors and chests. On the first turn, he just walked up to the cell door and opened it. His status screen showed no indication that he had this ability.

-Would it be possible to weight class rolls? By the end of the game, I had countless laguz units and many Herons. Most of the game could be cheesed in single turns because I could dance train my units through the maps. Also, because Reyson still came with his ability to dance despite being a Mist cleric, he was yet another dance train utility; even moreso after promoting and being able to canto. However, I could count on one hand how many other types of units I got; besides mages which were in OK supply, I got one armor knight (who sucked), two Myrmidons/Swordmasters (who sucked; no one’s got time for 8 Str and 11 Spd at level 10 promoted), one Rhys cleric (who was alright), one late-game Assassin (who would have been fantastic if he hadn’t shown up so late), one Wyvern Rider (who sucked), absolutely no Pegasus Knights, and other classes I’m probably forgetting because I barely saw them.

Anyway, that’s all I wanted to share from my experience.

Edit: well, that was fun while it lasted. Attempting another randomized run after clearing the game now simply crashes Dolphin with an “Invalid Read” error before the title screen no matter what I do, despite working just fine the last time. Not even moving/erasing the saves or messing with randomization settings solves the issue. It’s just one and done.


#112

I came across the same problem, although this is the first time I try the randomized.


#113

It’s the system.cmp file. Examining the command prompt when the randomizer does its thing, I noticed that the randomizer can’t access the file because it thinks its being used by another process.

To reiterate, I was able to get one successful randomized run out of it before the randomizer itself started having this issue.


#114

I rebuilt the rom it’s randomized but when I load it on dolphin I get a pop up that says
“Invalid read from 0x62bdee06, PC = 0x802344e4”
I tried rebuilding it as a .iso and .gcm nothing works please help me


#115

Watch the command prompt when running the randomizer. It will sometimes say that there is an error with system.cmp. Whenever you see that, you may have to keep randomizing until you don’t see that error.

In my experience, it’s about an 80/20 chance of it creating an error.


#116

ok thanks I’ll try that


#117

I have re randomized it 10 times and it’s still not working


#118

Try moving the root folder and randomizing again.


#119

I’ve tried that still the same error


#120

I’m not sure, then. All I know is that for me, after many tries, it just magically worked.

On an unrelated note, some other things I noticed during a new randomized run:

-Gatrie appeared as a Level 20 Wyvern Knight while Shinon appeared as a Level 9 Myrmidon. Apparently, they wanted to see what it was like to be pre-promoted/unpromoted, as Gatrie hit 21 by the end of the prologue.

-I got several units with the Canto (dance) skill. Enemies must despise any unit with this skill, because they regularly beeline for these units even if squishier units are in range.


#121

All right I’ll just keep trying thanks for your help


#122

I tried randomizing it from the start, and unlike CultivatedFinch suggested, no error message appeared when running the randomized: it decompressed and then compressed system.cmp without issues.
Here is said file: https://drive.google.com/file/d/1H5r5i5QrlFZ3Pfrm5UpZR-zoWYarz66p/view?usp=sharing


#123

I tried yours, and it worked the first time I tried it (didn’t get the error). After that first time, I started seeing the error in the command prompt.


#124

I haven’t had time this weekend to look at anything, but reading this i had a hunch why it would work only once pr file: There were file streams that i failed to close. That means it probably works once pr computer restart, since it needs windows to clean up after me.


#125

So my problem is different: I’m doing this for the first time and it still didn’t work…there’s the usual error and the command prompt doesn’t show an error with system.cmp.
If it’s needed, there is said file above.


#126

I’m also having crashes after randomizing and rebuilding the ISO. The unmodified ISO boots without a problem. I’ve tried randomizing the root folder seven times so far and each time I get the same crashes reported above, before the opening movie begins to play.

I am using v1_1_2. I did not see any error with the command prompt window.


#127

What build of Dolphin are you using? I usually use the nightly builds but I had to use the stable 5.0 version to get my randomized ROM to even work (as long as there was no system.cmp error). Nightly builds crash before the opening movie regardless if the ROM worked on the stable build.

For reference, this is what the command prompt shows me when it encounters an issue with system.cmp (leading to a crashing ROM):

This appears immediately after hitting the “Randomize, Save and Quit” button.