[FE8][WIP][25 Chapters][+11 Gaidens] Fire Emblem: Restoration Army (Attempt 3)

Quick report:
During chapter 6 and 7 some units got the wrong equipment and they can’t use it, for example a raider got iron sword.
During chapter 7 some enemy just go next to my characters without attacking them

And also for the man who summon the spider, when I reached lvl30 she had no more axe equiped but venomous fang so that’s good!

1 Like

Im playing through chapter 4, but my game crashes any time i go into a home and get an item, im using pizza boy in android

1 Like

During chapter x1 it’s possible to steal the silver shield on the skeleton, and since he spawns every turn with the same item you can steal the item over and over and since the item seems broken, I don’t think this is intended

Also I arrived to the new route and I have to select some characters, does that means that I won’t see the others ever again if I don’t select them? Also, are my items going to disappear?

Thanks

1 Like

I’ll look into this. It should be a quick fix. Sorry about that.

Honestly I just didn’t think anyone would survive long enough to get more than 2. But this will be changed, thank you.

To the spoiler, you will see them again, but it’ll be a while!

Bizarre. But good. I’m still going to stop him from being over level 20 for future builds. I don’t want that bug to occur again.

Hi, I am having trouble replicating your issue. It’s likely due to the emulator, but if you have any additional information about what settings you’re playing on that could be helpful in figuring out what you are dealing with.

The hack is only tested in MGBA, so other emulators may have strange bugs.

It’s easy to survive since you can prevent the others skeleton to spawn by sitting on their spawning tiles, so you can just farm the one with the shield very easily !

Thank you once again for your answer :innocent:

1 Like

So I have the issue of not being able to use statboosters too. HOWEVER, I’m also not able to use a master seal specfically on Freya, who I promoted to the Devout class. Notice that she can use light magic but not staves, even though the class description says that devout can only use staves. Personally I’m a fan of an armoured mage option, but thought this was good to point out:

Irene also shows up in the Silas squad route even though she should be with Ryne’s squad. She is even usable on S7, but after S7 she cannot be used in further chapters(“this unit is not avaible for the chapter”)

The Morgan telling Ryne that he found a lockpick scene plays mid S8, I dunno why.

1 Like

Have you updated to the newest patch? That issue is resolved there.

Thank you for pointing it out! It is now fixed. The “girl” version of the devout class was not included on the promotion table. (The staff thing is fixed too. Don’t worry when promoted they can be armored and have magic, you just got a taste early).

I assume you mean S8? This one is kinda weird as she should be removed when you complete parting of ways, though it seems to have been caused by the order in which you had units leave the chapter? Regardless I added an additional event to specifically remove units who are locked to Ryne’s route.

I assume you mean S9? But I do know why :face_exhaling: . It’s now fixed.

Thank you very much for reporting these to me.

well, I used the new patch. And two things happen:

While the cutscene is playing where alfonso attacks the soldier trying to attack the group, silas’ sprite is shown instead and the game gets stuck,

If I skip all the cutscenes instead, on the map I’m stuck without a pointer, like this:

And I’m unable to continue the game. Also the playabe pirate(the other guy who is not jason) gets a cleric as his sprite when you look at him in the info screen,

I’m going to look into this, but I think the cause is that the rom is too large which is causing data to be moved around. I have a rebuild but it won’t be compatible with your current save. So I’ll see if i can fix this error.

Sorry that it even happened

Has this issue been fixed? I love hacks with lots of trainees and I really want to finish this one soloing the game with Silas.

This might just be a skill issue on my hand but man the gap between normal and hard mode is a large margin. I was able to breeze through on normal but on hard it had my head scratching even at chapter 0? (the escape one). That being said I love the hack!

2 Likes

Did you beat it? My strategy was to turtle. Note that I also suck at FE but this is how I beat it anyways. Try and stack alot of avoid if you are going to turtle It doesn’t matter if Quinn is in a forest tile but for Irene it does. Even though Morgan has higher defense than Quinn, her and Irene are going to be the ones fighting for the first few turns. Save some hatchet uses for chapter 1 and 3, Quinn has the slim lance which grants 15 avoid when attacking. When Lynx arrives don’t worry about him too much just move him closer to the group. Once the reinforcements slow down you can start to move towards the escape tile. This is what my blob looked like:

I would say everyone has a job here, Morgan buffs and trades around vulnerarys for the group, everyone else defends him.

2 Likes

I have not fixed it (I think). I haven’t worked on the hack in a while because I have a huge exam coming up and I have been studying for the past month. Once I’m done I’ll see about adding the rebuild patch (but old saves will be unstable with that version).

4 Likes

Okay, first, this hack has improved tremendously. I sincerely believe that it could be one the best at the rate it is improving. Which bring me to my criticisms…

Nora’s Villager class is a promoted unit in the games files, so leveling her up to even be promoted is nearly impossible. Also she has access to anima magic, and I feel like she isn’t supposed to, especially if Ryne isn’t. Ambar’s Wooden Flute is also an enigma, as it looks like it’s kind of a weapon but also doesn’t function as one? It’s a very confusing item.

I’ll add more later if I have anything else.

1 Like