[FE8] Skill System v1.0 - 151 skills done, more on the way


#307

There is a patch in FEBuilder that can install the skill system with no boss rush. If you want to use build files, do the following to remove the boss rush chapter:

  1. Open the main build file and comment out the events and maps sections.
  2. Open “./Text/text_buildfile.txt”. Remove the Boss Rush entry at 0x160 as well as the HouseText and VillageText entries. Renumber the other entries with new offsets starting at 0x0D4C (for a vanilla ROM). Do the same for any files that are referenced in the text_buildfile.txt.
  3. Delete the textentries folder. Run the textprocess program on the text_buildfile.txt and verify that the new event files were renumbered correctly (none having indexes lower than 0xD4C or your chosen starting point).
  4. Open "./Tables/FE8 Nightmare Modules/Chapter Data Editors/Pointer table editor.csv” and change the “0x04 Prologue Map” value to 0x81b76f4 and “0x07 Prologue Events” to 0x89e863c.

This should allow you to start a new game like normal.


#308

Thanks. I’m trying to create new skills and stuff to add in personally, so this really helps.


#309

Problem: Assemble_Arm.bat isn’t letting met assemble a .dmp file for my new skills - or any old ones, for that matter. It gives me the error “bad expression - ‘ldr 0, =#0xFFF80000’”, then just stops. As far as I can tell, this also occurs with any old skills too


#310

The error message you’re getting looks like you’re trying to ldr into 0 instead of r0, which isn’t possible. Check your asm to make sure.

However, if your assembler .bat isn’t working even on existing skills, it might be that it isn’t compatible with how/where you’ve got your devkitPro set up. If this is the case, it won’t load the right language specs and will throw errors on stuff that’s perfectly legal to do.

This one works for me, just make sure that startDir is set to the path to your devkitPro:

[details=I can’t upload .bats here so paste this into a text file and save it as Assemble_ARM.bat]```
@echo off

SET startDir=C:\devkitPro\devkitARM\bin\

@rem Assemble into an elf
SET as="%startDir%arm-none-eabi-as"
%as% -g -mcpu=arm7tdmi -mthumb-interwork %1 -o “%~n1.elf”

@rem Print symbol table
SET readelf="%startDir%arm-none-eabi-readelf"
%readelf% -s “%~n1.elf” > “%~n1.symbols.log”

@rem Extract raw assembly binary (text section) from elf
SET objcopy="%startDir%arm-none-eabi-objcopy"
%objcopy% -S “%~n1.elf” -O binary “%~n1.dmp”

echo y | del “%~n1.elf”
pause


#311

well apparently my version of “arm-none-eabi-readelf” is incompatible with windows x64 so

edit: so i got a version that does work, but we’re back to square one with the same error, even though i replaced my assemble_arm.bat with yours, and i’m getting that same error whether i’m making my own proc_bonfire or using an existing one, like proc_bane


#312

Chapter 2 (using the Vanilla FE8 skills) When I talk to ross It always gives me an error: Jumped to invalid address 04E3A020 if someone know how to fix this please tell me


#313

Has anyone ever had problems with Trample not working? Because it isn’t for me, my units just won’t get the damage increase


#314

Are you playing with vanilla?


#315

Nope, I hacked both prologue and ch.1; I checked the damage output against both monster classes and “human classes”; if it matters, I have Trample set as a personal skill


#316

IIRC Trample is one of the few skills that isn’t functional yet and only displays its icon.


#317

the tower of valni could not be accessed in my game using this mod.
anybody could fix this bug?


#318

Hi, I wanted to know if there was any way to edit the stat bonuses given by the “_Blow” skills, which are interesting but a bit OP, from my testing. In particular, I want to edit WardingBlow to only give +10 RES on player phase.


#319

Which skills are the ones that aren’t functional yet and only displays its icon? :c


#320

Trample, Opportunist, Triangle Adept, and Nullify, off the top of my head. I’ve actually just coded those (just finishing up Nullify) and will add to the skill system soon, once I add a couple of others.


#321

Thank you for the quick reply! I was sorta skeptical when I saw those skills weren’t on any classes, and I never woulda guessed without extensive testing. That’s good to know! Can’t wait for the updates.


#322

I think Solidarity is giving off the Hawkeye skill.


#323

yeah, the icons for solidarity/hawkeye/vantage+ seem to be mixed up


#324

Is bowrange+ functional… And is there a list or notes with all non working/ buggy skills listed?


#325

This is true for the most part, although it’s not always updated so it might be wrong for a few skills, as of bowrange+, it would take you just as long to test it than it would take me so just test it yourself really, but I remember it working.


#326

thanks… I wasn’t entirely sure if the skill not working was universal or if it was a problem with my build etc. I also noticed some skills were switched around mentioned above and was looking for a heads up for any other skills with similar problems so I wouldn’t have to resort to asking around.