(FE8 Romhack) The title screen of my hack is broken. How do I fix it? [Solved]

Hi, I’m new to FE hacking. In fact, this is my first hack, and while the development has been shaky (changing from one game to another, learning how the EA, Hex Editors and FEBuilder works) I’ve been able to make some progress… Until now, since during testing of the first map, I encountered this

when I got a game over. It also happens when I use “suspend” to go back to the title screen. I used OP LOGO BACKGROUND to change the title screen like one of you guys sugested in another post, and now it doesn’t even let me change or add another background. Please help!

FEBuilder generally automatically creates backups passively! Worst case scenario, you can just roll back to a previous version.

To do so, open the folder where you have your file, and extract one from the backup ZIP files. (They’re usually named "Project Name.backup.gba)

Then, once you have your GBA file, all you have to do is rename it to whatever you like, and problem solved!

1 Like

No clue but I had one too that turned the bottom 80% of my text boxes black and tbh I kind of wish I could make the whole thing black as it fits the theme better. I might have made too many extra hex vals, sometimes weird stuff happens if you add too much space to the game. I design parts of hacks I never post in my free time and in this one you are the bad guy raising your own army of undead etc etc.

Thanks for the reply! But now that you mention backups… Doesn’t FEBuilder let you do that directly from the app?

Or the backups work differently?

I’ve seen games like Justice & Pride that don’t change the title screen that much, but other games like the… ahem. Blinding Bald one, that changes the title screen without even using the OPLOGO BACKGROUND patch. I’m wondering how to do that.

Whoa, to be honest I didn’t know FEBuilder had an “undo” function like that.
I guess we learn something every day.

Aside from that, if you can’t use the OPLOGO patch, try using the patch “256 color title background”. That worked for me!

1 Like

It worked, there’s no more glitchy backgrounds when the game returns to the title screen! I’m so glad I made this post! I didn’t even know that the 256 color title background existed! Seriously, thank you so much.

1 Like

Hello there internet person i too seem to have this error but the whole title background is black and none of this things work should i just change my rom hacks name age of Darkness so the black background fits or is there another way to change back the title background to its original state

If a patch doesn’t work, the recommended thing is to just revert to a backup before the patch and either try again or do something different.