(FE8) Need emergency help with this crash


#1

I’ve already created and inserted many maps without problems.
But this one is driving me crazy:

  • It’s a new map for CH10B (Ch.10 for Ephraim)
  • The map plays out perfectly without issues during the main story mission.
    All events, units and tile changes work perfectly work too.
  • But when I enter this map during a skirmish this annoying thing happens:
  • During the preparation menu, there are no problems; you can check the map, all units (ally/enemy) are loaded without issues and you can even swap units around.
  • However as soon as you press start (during the preparation menu) to begin battle
    the game will crash.

How do you know it’s a map issue and not an event one?
To make sure, I went to the original map pointers and revert them back to their original numbers
(so that the game loads again the original map with its original tile changes).
BTW these are the original map and tile changes:
Map: 0x81B35B4 (Pointer is at 8B37F8)
Map Changes: 0x8A1EAF0 (Pointer is at 8B37FC)

I didn’t change the events or unit positions, just the map and tile change pointers.
When I did the above, and entered the skirmish again
of course the units and enemy units were all over the place (since they are configured for the new map)
however, I could start battle without the game crashing.
Which points me that the new custom map has some issue I can’t find.
I tried and checked everything but this is the first time the game does that.

Can a wizard find what’s the problem?


#2

Probably, I think there is a problem with the unit you are loading.
Among those units, is there a unit that moves when it appears?

If the point where the unit moves is a non-movable tile such as a wall, the game crashes.

For example, if load this map into the prologue, seth will appear above the water.
Since seth can not move above water, the game crashes.

If you are using FEBuilderGBA, it is very easy to reproduce it by making 7z of ups data using File -> Menu -> problem reporting tool.
It includes multiple ups data and save data of the emulator, making debugging very easy.

I did not have time to advance the game till chapter 10.
For that reason,I did not actually check it in Chapter 10,
The coordinates of the destination of several units are walls.
Probably, I think this is a problem.


#3

No.
I know about this during events. But this is a simple skirmish.
Units just load and are immobile. No scripted movements.
Also checked all units 1 by 1 again and all of them are on movable tiles. Also no units outside the map.

Like I wrote in the OP, if I just recall the original map with its original tile changes
there are no problems, even though the current unit positioning has them on top of walls.
Right now the game crashes as soon as the battle starts (and no problems during the preparation screen where you can view the map or change positions.)

Can you check something? :
There is 1 odd thing. I have a Tile Change with ID “0”. This ID 0 is supposed to activate during skirmishes.
The tile change ID0 should cover all the villages and houses and turn them into ruins during a skirmish.

Here’s the problem: The tile change ID 0 does activate for all except the most northern village [which has 2 tile changes; 1 for getting destroyed-ruined (ID1) and 1 for having its gates closed (ID2)]

ID0 tile change can’t make the ID1+2 village look as ruined.
Instead I always get a ruined village with closed gates.
If I made ID2 a whole closed gated village, in that case the game would show an intact village with closed gates.

Basically the game seems to try to load ID0, ID1 and ID2 together.
Any ideas?


#4

i see.
Since I want to reproduce it, I want an ups file and save data that can play that chapter.


#5

I’ll make a copy and send it to you


#6

I was wrong one.
This translated Google “during a skirmish” as (戦闘中に)“during battle”.
This is during a world map skirmish, in Japanese Communities it is called a free map.
So, I could not understand the meaning well.

The bug was reproduced.
However, this bug caused the no$gba debugger process itself to crash as well.

I have experienced a phenomenon similar to this.
That is when I accidentally made an infinite recursion and caused stack overflow.
Again, the no$gba debugger process itself crashed and it took a while to locate the bug.


#7

Was it caused by the new map?
Or is it chapter event related? (Even though it is a Free Map Battle)

In the end, is there a solution?


#8

So I tried removing all events from the chapter
and inserted a modified MAP without any tile changes, shops, villages or houses.

The game still crashes on starting the skirmish.

At this point I’m forced to either
a) revert back to the original MAP and re-write all and every event from scratch which would suck (please no)
b) someone can at least tell me how to “shut down” skirmishes from happening on this MAP.


#9

It seems that infinite recursive call has occurred.
The function called when the start button is pressed looks like 0x08002e28.
This is a general-purpose function called by Procs.

It seems that an infinite recursive call has occurred at the end of this routine.

I studied how to get rid of it.
Then, when creating a tile change up to 0x07, it no longer crashes.

Currently there are only tile changes up to 0x4.(It counts from 0x00. There are five in total).
Originally, in this map tile change is registered up to 0x07. (When counting from 0x00, 8 are required).
Perhaps this could be causing problems.

I have to investigate more why the problem will occur.
However, if you create a tile change up to 0x07, you may be able to remove the crash.


#10

Thx for the advice.
I’ll try it later when I have time.


#11

Thank you. This solved the problem.
本当にありがとうございました