[FE8] [COMPLETE] Iron Emblem (v1.3.1.1, Full-Length) RR Out!

I’ve had this hack sitting partially complete for ages and finally finished my first run today… “finished” meaning getting completely destroyed in the final chapter lol. I assumed I’d have to play hyper aggressively and was very wrong. The final few chapters were mostly not that hard, so Endgame felt like a huge difficulty spike until I realized the assassin reinforcements weren’t that aggressive and I could’ve taken my time a bit more. RIP :pray:

Skimming through posts here, I apparently was playing on a very old version! My convoy stopped working entirely about halfway through the game (deleting a bunch of master seals I had lying around, so I had a few unpromoted units in the endgame including the Commander). Knowing now that that bug was known and fixed, and seeing that some chapters even got nerfed in later builds, I feel much better about how far I got!

Honestly, I actually had a lot of fun playing without a convoy. Sometimes I had to make some painful choices about inventory that were very fun to make, and I had to be very conscious about my shopping trips. It really added to the hardcore experience. But it WAS exhausting, and knowing it’s fixed makes me more willing to try a second time and hopefully do better.

Instead of full team screenshots I’ll just post my favorites:

GOATs







  • Honestly, even if my master seals HADN’T all vanished into the aether, I didn’t even realize you could promote the Commander and probably wouldn’t have thought to. For some reason I always assume you can’t promote lords lol
  • 24th Squad 4 was the best character on my team, easily. Was never not immensely valuable. Ice cold take no doubt
  • Hired Blade 8 was not even promoted until the Dragon that joined in endgame delivered him a master seal, and he STILL always put in tons of work as a Mercenary (5 move in the lategame was agony tho)
  • Mage Corps 4 got a couple of surprisingly great levels early on so I gave her the Afa’s Drops. She was consistently amazing throughout as a damage dealer and was one of my few S Ranks I was actually able to use in the endgame (for all it helped lol).

There wasn’t a bad chapter in this hack (once I realized what I should’ve done in the endgame), but my favorite map was the first defend map. My team was stretched to its absolute limit trying to stay alive and keep the diamond-marked enemies at bay. Fantastic stuff.

I didn’t understand the manakete unit. Decent Atk and Def but awful Spd and HP meant it was horrible at every job. Terrible unit and the only one I felt nothing about when it died (besides confused). Every unit besides that one seemed to have valuable purposes - I’m in love with the balance of this game. Any insight on the manakete that I should know for my next run?

Thanks for making such a fun and unique hack! I’ve never had to try so hard and sweat so much playing Fire Emblem before haha. This seems like it would be an amazing game for streams. GG

Edit: oh and closing thought! I didn’t have any S rank Light magic users but I still threw away a perfectly good sword in exchange for “Holy” in hopes I could sell it for more E rank weapons in the endgame. Was very sad I couldn’t. :pensive:

5 Likes

It’s meant to be an Est type unit, but you kind of get it a bit too late for it to be viable to train it up that much.

This was fixed in later versions iirc.

The convoy thing seems to have resurfaced recently? I’m not sure, but I’m not updating the game any more so there’s not much to be done. It should be fixed in 99% of playthroughs, though.

Glad you enjoyed the game.

3 Likes

1.3.1 out at the dropbox
Only did NM because I’m a bit lazy but HM will come down the line, probably.

Changelog

Fixed heal animations (read: removed them completely)
Fixed defend bug where when the enemy escaped it wouldn’t trigger gameover
Fixed bug where destroyed villages could still be visited
Narrow numbers have been implemented (thanks epicer), hopefully reduces the amount of menu glitching even if it’s not completely eliminated.
Lowered ballista pricing again, also made them more durable (+2 uses to arrowspate/stonehoist)
+1 turn to Ch13 timer
Very slight buff to a couple of endgame greens
Very slight buffs to ch7
Fixed those damn battle backgrounds, I think. I swear I had fixed them earlier, those things have been bugging me forever.
Slim Axe durability lowered from 30 to 25
Thief Def growth lowered from 30% to 20%, Thief HP growth raised from 60% to 65%, Thief Str growth increased from 25% to 30%. Reason is that this was a complete oversight, I never intended for them to have 30% def growth, but they’re also really bad, so hopefully the buffs compensate for that.
Assassins in endgame should work as intended (go for escape point but attack if blocked), this hasn’t been tested thoroughly so let me know if there’s odd behavior and I’ll see what I can do
Medic Crps palette has been fixed he is no longer Artur.

This one is almost definitely the last update, since a lot of what was fixed was just extremely annoying bugs that have been highly reported. Shouldn’t be any left that are too big of a deal. If anyone finds anything though, let me know asap.

4 Likes

Loving this hack so far. However, a blurb at the start of the game mentioned referencing the guide for further details (promo bonuses, etc). Was unsure where this guide was located, couldn’t find anything in this thread?

FE Iron Emblem-2

2 Likes

So, I was enjoying the game quite a lot and suddenly I can’t progress because as soon as I start chapter 9 I get a game over.

Might not be a bug. I restarted the chapter before starting the map (which should be fine) to make sure I didn’t miss anything and maybe I clicked enter on accident before reseting the emulator, not sure, I don’t remember starting the chapter but it’s possible

Is there any fix or do I just give up?

EDIT: if possible and easy to implement, I’d personally recommend only forcing a gameover after actually moving a unit so stuff like this doesn’t happen. The preparations screen isn’t really supposed to be somewhere were you need to be careful with your inputs imo. I’m biased tho

Was not able to replicate this issue, sorry. Maybe if you can provide a more step-by-step of what happened I can try to replicate it but as is it doesn’t seem to be happening no matter what I try, can’t see anything else that would cause this either. My best guess was that you did accidentally hit enter prior to resetting the emulator.

If you want to undo this in builder, you can either remove the event on turn 1 or use cheats to turn off the flag that is checked during that event.

I do understand where that last bit is coming from but I don’t have any idea how to do that, and even if I did, I do think that making accidents even during preps can lead to a more interesting experience and I like what it can do, though obviously I get how it can be frustrating too.

Good Day! I also experienced what LordMudkip’s shared however mine is on Chapter 5. I tried restarting the game, the chapter, and even copying then playing the copy but still no fix. What can I do?

What do you mean by restarting the game didn’t fix the issue? You should be able to just erase the file and start a new one iirc, maybe try a different slot?
I’ll look into it, though.

I tried restarting the emulator and still got the same result of getting the game over screen.

So I’ll just start the run over again to be able to continue?

Update: Deleting the save file fixed the problem, it sucks but I’ll take it

If you’re talking about the softlock that occurs when you restart chapter after preparations, this is intentional. I’m not sure what else it could be since I’ve played through the game recently and didn’t notice any issues like this, and I don’t have much information on the specifics of the issue.

1 Like

Hard mode has been temporarily removed from the dropbox, it will be added back when I update it.

Oh, i finished this hack, which well… congrats me (no emulation savestates for meee). Even if it’s on normal, i am proud of myself.

Well mostly because I never did ironman run before so this was literally introduction to this type of play. I must say hack is prepared masterfully for this. There is no bullshit ambushes as reinforcements are labeled very well or at least appear on other side of the map so you can plan many turns in advance (this often happens in later maps). The maps are simple but have clear objectives and side objectives and they can be reasonably done assuming you wont screw up and lose too many good units. While i lost many units, i never felt it was game fault, but simply me not planning properly (maybe except last map - that one is carnage and a half. Then again its last one so its not really problem).

The only issue really i guess was map with bandits in second half, maybe a little too many reinforcements being too close to you but then agin maybe i just had brain fart that caused me to lose like 3 units. shame on me.

I also really liked the… presentation. Having bands of generic people (literally 2 portraits) while them having unique nicknames makes you attach a little but not too much. I also liked the small descriptions of enemy bosses. The story also shows that its “just another brutal war” and you arent really the good guys anyway, you just happen to be on side B than side A. You never even learn why war started (or i forgot if it was mentioned at chapter 1), but why you would care? You are just one of many commanders.

Ther eis also no supprts which is great but perhaps supports for people from same squads would be nice. No, not building thorough the game, but starting with some for flavor reasons. It’s not like supports bonus break the game and it might be nice flavor i think.

I am looking forward for more Iron Emblems and who knows, i might try ironman run because of this on other fire emblems, regular or romhacks. I am very glad i tried this hack! :smiley:

4 Likes

Hello! Recently picked this romhack up. I’m at Chapter and I am currently stuck

The objective says to “seize the throne” yet when I place any of my units on the throne, the “seize” command doesn’t appear?

Am I tripping or something? Is this a bug perhaps? Like the command for “seize” literally does not appear on any of the units I place on the throne to seize.

Thanks!

1 Like

Nevermind boys. Turns out you had to use the Commander to seize. I didn’t even know there WAS a commander, I thought they were all the same.

2 Likes

Ok I most like this hack, but I have 2 major concerns.

  1. (This is just my luck honestly) I got 20 level ups in a row that were only hp
  2. What in the ever loving name of Kaga were those reinforcements in chapter 4. Like 20 cavs with silver lances.
2 Likes

Ha ha. When I got to that chapter the first time. I took everything so slow when I saw those Cavalries reinforcement with the Silver Lance I knew I had to Restart and Go Fast or Go Home :joy:

Use everything at your disposal even the archer units on the top of the map can help you clear a good chunk of the enemy. You just need to be careful with them and use your vulnerary to heal and bait out the axe user

1 Like

its society punishing you for taking 12 turns

3 Likes

1.3.1.1 has been pushed to the dropbox. Pretty minor update but there were a couple things I wanted to change and it didn’t take too long.

Changelog

24th Sqd 1 Str growth 35->30
Grunts 3 Str growth 45->40
Pro Crps 2 C->A swords, C->B lances
Pro Crps 5 D->C swords
Armor Squad buffed
Experience gain disabled after turn 15 on every map (subject to change, I can push it back a couple turns)
Commander’s promotion is now similar to FE1/Gaiden. He will be raised to certain stats if he is below them, but gain nothing if he is above them.

5 Likes