FE_Builder_GBA


#1883

In the latest version, I replaced it with your translation.
Thanks.


#1884

Please send report 7z.
https://dw.ngmansion.xyz/doku.php?id=en:guide:febuildergba:report7z


#1885

Yeah, I was able to pull it off after the direct translation was shown. Thanks though, that could help in the future.

Edit (so no double post):
I found some other text that was cut off in the description.

Edit 2: I’ve been working on a ROM and FEBuilder claims there’s no more free space left. I can verify, however, that there is quite a bit of free space - the amount of which depends on whether it defines free space as 00 or FF. If FF, there are about 8 kilobytes of free space around, and if 00, there’s over a megabyte. What is going on?


#1886

I had a similar problem before and @7743 showed me that the error was that an unmounted unit was walking through a physical barrier, in my case it was a wall, in your case maybe its the water or the thick trees (depending on which tile you used), and the game couldn’t accept something walking through a wall. Maybe thats the issue


#1887

This problem has been solved.
It was the same problem.

It is a problem that occurred because he tried to move a unit from a non-movable area surrounded by a deep forest.


#1888

I fixed the translation with the latest version.


#1889

This happens to any ROM, even vanilla. No report.7z needed.

Also this might be a good patch to add - advances the RNG seed every frame so that the same thing doesn’t happen every time you play the chapter.


#1890

How do I warp in reinforcements after all the enemies on a given map are defeated?
Also how do you remove the hardlock on the units allowed for any given chapter (such as Natasha chp 5 or Tana Chapter 9a)


#1891

How do I warp in reinforcements after all the enemies on a given map are defeated?

I think to hook flag 0x06 with AlwaysCond and create reinforcement event.

If the enemy rout, Flag 0x06 will be automatically enabled.
This process is a chapter aimed at annihilation of enemies, please refer to it because it is used to judge victory conditions.

https://dw.ngmansion.xyz/doku.php?id=en:guide:febuildergba:how_to_make_victory_condition_en#make_the_rout_enemy_stage

Also how do you remove the hardlock on the units allowed for any given chapter (such as Natasha chp 5 or Tana Chapter 9a)

MENU->Detailed menu->Forced Deployment


#1892

I fixed with the latest version.
Ver. 20181123.17

If you can send report 7z it is the most reliable way to send it.
There are many problems that can not be reproduced without report 7z.
In addition, it may take time to reproduce.
It will take my time away.
Of course, if the problem does not reproduce, you will take your time by interacting.

The best way to not waste time with each other is to send report 7z.


#1893

(Edited this post because I didn’t have the version that just came out.)

Yeah, I know that report.7z is always useful, and I get why. I just thought it wouldn’t be necessary this specific time because it was a simple step that happened even on a vanilla ROM. Thanks though.


#1894

Okay so I edited the Chp 17b River of Regrets map and made something fairly decent but I noticed that all the changes I made on that map were also happening on the Chp 17a River of Regrets map. Is there a way to remove the link so that I can edit each map individually?


#1895

Insert a new map in freespace using the Map editor, and then in the Map PLIST, look for the Map data for 17B, and change the pointer from “Narube River” map to your new map.


#1896

Thank yous


#1897

7743 it’s just my thought but if you can include a changelog after every update of febuilder that could be great


#1898

I do not write it because it is troublesome to write changelog.
If there are important changes, notify.

Guys will not read even if I write it. :slight_smile:
Most users do not read manuals either.

If you want to know the change history please read git’s history.

By the way, have you seen changelog of v8 engine of javascript ?
Looking at this, We can understand the significance of changelog.

In other words, There is no meaning.


#1899

Thanks. At least i know where to read it whenever an update appear.
Edit: either i am dumb or i can’t find any of [quote=“7743, post:1898, topic:2845”]
git’s history
[/quote] you’re talking about. Sorry for my foolishness


#1900

If you clone/checkout the git repository locally, you can use git log on the command line to see the commit log.


#1901

I didn’t understand anything of that so i guess i’ll pass. Thanks for helping me anyway.


#1902

Made a bunch of edits in FE6 using FEBuilder, then when I go to play the game, it freezes whenever I attempt to save after completing a chapter. I was wondering if this is a common problem experienced with FE6 and if there is a way to fix this?