FE_Builder_GBA


#1316

I tried to do this in the new ROM, and it turned out, as you did, that it was error-free. I think he might have been in conflict with another patch.
I think I have almost solved the icon bug now. If I put the icon I imported into the original system icon, it won’t happen.


#1317

Unfortunately, it will not work.
Perhaps, I think there is FE8CN that I do not know.
Since FE8CN is Hack Rom, it is no wonder that there are multiple versions.

In FEBuilderGBA, it is defined as follows.
Please calculate CRC32 of your not remodel FE8CN ROM.
I know FE8CN, CRC32 is 0x79609D14.
Perhaps your FE8CN is not that value.

I think your FE8CN is a different version.

//NAME	VER	LA	HEADER	ROM_SIZE	CRC32
FE6J	6	ja	AFEJ01	0x800000	0xd38763e1
FE6U	6	en	AFEJ01	0x1000000	0x35F5B06B
FE6CN	6	zh	AFEJ01	0x800000	0x1F19D989
FE7J	7	ja	AE7J01	0x1000000	0xf0c10e72
FE7U	7	en	AE7E01	0x1000000	0x2a524221
FE7CN	7	zh	AE7J01	0x1000000	0x5F286460
FE8J	8	ja	BE8J01	0x1000000	0x9d76826f
FE8U	8	en	BE8E01	0x1000000	0xa47246ae
FE8CN	8	zh	BE8J01	0x1000000	0x79609D14

#1318

Oh, what a pity


#1319

Thank you. You’ve been really helpful and I greatly appreciate it.


#1320

I mistakenly wrote the address to extend the height of FE 8U’s portrait.
This bug was fixed in Version: 20180605.06.

For existing data, please correct with the following address.
8005C98 To Stretch out
8005C9C Do not extend back


#1321

I’m having a problem with the Change the Level Upper Limit for Each Individual Class and Unit patch. When I individualize each class, I end up with everyone maxing out at 1+Their Original Unit Level. Is there a patch that interferes with that or am I doing something wrong?


#1322

Well, if it is version 2018/4/3 or later, the bug should have fixed.
Therefore, it may be an unknown problem.

Could you send me an ups patch and Emulator’s SAV data?


#1323

You’re right. I erased the old save, reinstalled the patch and tried again and it’s working fine.


#1324

Okay yeah, I manually updated and it auto updates now
I was using a build from November of last year, and I thought I’d updated since then. Obviously I hadn’t.


#1325

Version: 20180607.00 has been released.
Please try to obtain this version with automatic update.

If it does not work please send log.txt.


#1326

It offered me the choice to halfway through using it, so I’ll update it after I’m finished making my changes and update you on that.


#1327

I created a report with the new problem reporting tool.


#1328

What do I do when I get this error message?


#1329

After all, did the update succeed?
In case of failure, I want you to send me a log.


#1330

How can I reproduce the problem?

In Version 20180607.21, I updated the problem reporting tool.
Please update the FEBuidlerGBA and send the data again.

In the previous problem reporting tool, it was not able to acquire the save data of the emulator.

I do not understand how to reproduce your bug.
In the new version, since the save file of the emulator is also included in the report,
if you create a report with problem reporting tool after reproducing the bug,
I will be able to reproduce the bug easily.

Therefore, please send me a report with the latest version of FEBulderGBA.


#1331

And another one.
I have noticed, watching your ups.

You are adapting two save data extension patches simultaneously.
If conflicting patches are installed at the same time, it will not work.

“Class Expansion” and “Raise Stat Caps Above 31 Points” are patches that change the format of save data.
It can not be used at the same time.


#1332

Normally, the error message is displayed when the character string is three lines.

For example, the following text has three lines, so the error is displayed.

1111111111111
2222222222222
3333333333333[A]

This should be fixed as follows.

1111111111111
2222222222222[A]
3333333333333[A]

However, if I look at your error message, you will see a Kanji code on the way.
How did it happen?
Please send me ups with a new problem reporting tool to reproduce this as well.


#1333

Yeah idk where the Kanji code came from but I erased it and added the [A]. It took me a while to realize what that actually meant. I am fixing the manageable errors and will create a report shortly for the save issue


#1334

This is the error report


#1335

How did you see the Kanji code?
I want to know why kanji was displayed.

Normally, in the English version, it is impossible for kanji to be displayed.
What have you done?

If you explain the phenomenon, the following cases are considered.

#1.
Adapted DrawMultibyte Patch and converted it to display mode of kanji.

#2.
When rewriting the text, I directly designate the character code of Kanji by using the mode which directly applies the hexadecimal code, such as @0003 instead of [A].

#3.
Other phenomena

In the case of #1,
The DrawMultiByte patch is used for translation.
Please do not use usually.

In the case of #2,
In FEBuilderGBA, “@” is reserved for hexadecimal escapes.
If you want to write @ in sentences, please specify “[@]”.

In the case of #3,
Please explain how you did it.