FE_Builder_GBA


#1296

expand the size of a prop using an icon in an icon extension

I do not understand the meaning of this part.
What does “size of a prop” mean?
Please explain in a more detail.


#1297

Can you explain how this happened? I haven’t been editing as much but as soon as I update it, this came up.


And when I tried to run the game, this happened to me

And this frame here is a frozen loop that I’m assuming means the game doesn’t know which animation to go to but please correct me


#1298

There is no log folder in my config folder.


#1299

You seem to be using a very old version.
With the current version, I create a log directory so that I can log errors.


#1300

It is now displayed because FELint has expanded the range to check.

The content of this error,
you are making an ax that can throw 0xD1 weapons.
However, the unit that can use this ax does not hold the motion that throws ax.

For example, please look at the general battle animation.
The ax that can be thrown is set individually.
It is unnecessary in the case of a sword or a spear.
Only the ax that can be thrown needs to be specially specified.

This is the specification of GBAFE.
Axs that can be thrown need to set hand axs motion individually.
Otherwise, battle animation will freeze.

FELint points out that.
You made an ax called Requiem at 0xD1.
That ax capable of range attacks such as 1-2.
However, you have not set that motion to a unit that can use an ax such as 0xB General.

However, I do not know if this is the cause of your battle animation freezing.
Information is insufficient.
If you want to solve the problem completely please send me ups file.


#1301

#1302

Extension items use the extension icon


#1303

I was a little sleeping, so I got late.

As a quick way to solve the problem, uninstall the following patch.
DSFE Growths(Total growth = character growth + class growth)

Your ROM is corrupting the stack in the function for the growth rate.
The push / pop relationship of the stack has been broken.

Therefore, I searched for patches that you are using with a patch seeking growth rate.
So I found this DSFE Growths.
Uninstalling this patch resolves the problem.

However, in general, DSFE Growths works properly if it is standalone.
I think that it competes with any other patches.

I have to investigate more which competing with other patches.

Also, to turn off the FELint warnings, please do the following.
Set the attack range of 0xD1 Requiem to 1-1.
(If you want to change 0xD1 Requiem to 1-2 please set motion 0xD1 Requiem to a class that can use axes.)

Also, the brigand class is not enough to designate ax.
Please add Tomahawk and Hatchet.

With these two fixes, all warnings disappear.


#1304

Extension items use the extension icon

I tried it.
I do not think there is any problem.



I extended both items and icons and made a sword MySword on Item 0xFE.
I think that it works without problems.


#1305

Can you swing the bar up and down, left and right?


#1306

swing? I do not really understand.
I upload the ups file, so please try it.
https://dotup.org/uploda/dotup.org1549818.7z.html

This ups is a patch for FE8U.


#1307

Oh, I don’t have the fe8u, it doesn’t work


#1308

You can see


#1309

Mr. 7743, I have a bug here. Can you help me solve it? I set up a shop, but I couldn’t get in.

and what I could get in couldn’t buy props, like this.


#1310

Well then I will give you a patch made with FE8J.
https://dotup.org/uploda/dotup.org1549871.7z.html

Since FE8CN is FE8J’s Hack Rom, you should have FE8J.


#1311

Probably because flag 0x09 is valid, I think that the event has already been processed as having occurred.
Please set this flag to 0. (0x9 -> 0x0)

It is unreasonable to set a achievement flag in a store.
This achievement flag turns ON when an event occurs.
Once the flag is set, the event is considered to have occurred, and it will not work the second time.
In other words, this shop, once entering, will never enter the store again.

Also, if you have never entered this store, I think that flag 0x09 is in effect at other events.
Either change to another flag or not to set a flag at all.


#1312

I set the sign to 0, but the weapon and prop shop still can’t buy it, but it can enter


#1313

I think my ROM is fe8cn and it can’t use this patch


#1314

If it became possible to enter the store, we made a step forward.
I do not know why items can not be bought.

I think that you broke the routine to check your money.
I would like to confirm if you send me ups, but your ups do not work well.

How about using the diff debugging tool and comparing it with the version that worked last?
http://ngmansion.xyz/wiki/hackfe/index.php?解説/FEBuilderGBA/3点DIFF错误的自动检测_ZH


#1315

You can try this patch
Links:https://pan.baidu.com/s/1iX8ldIybiL_FzSefhbeQRw
Password:5g13