FE_Builder_GBA


#1195

Fixed in Version: 20180512.02.
Please update.

Since it was reported that Lint issued a lot of errors after setting the end of the battle conversation to 0x00 0x00 instead of 0xFF 0xFF,

Therefore, even if there is a frame filled with 0x00 all, I ended there.
However, in your ROM it seems that the first frame of the battle conversation is filled with 0x00 0x00 or 0xFF 0xFF.

I reviewed the routine to detect abnormal termination.
If it is data other than the first one and more than 10 pages are filled with abnormal data, I changed it as the end.

If you still have problems, please send me an ups patch.


#1196

Thanks for the quick reply. Its fixed, thank you.


#1197

I am glad that the problem was solved.
If you find another problem, please give me a report again.


#1198

The 600th crash report arrived today!

When an unknown error occurred last November, a screen for sending a crash report will appear and you can send me a message.

The total of that message has reached 600 items.

I have read all the reports I got.

I have already fixed the problem that can infer the cause.
I think that the problem of about 90% has been corrected.

If an error occurs, please send me a report.
Also, the problem that is not fixed is the problem that can not be identified.
In that case please send me ups patches and data.


#1199

Mr. 7743, may I ask how to make the extra additions in the last chapter to continue in the next chapter? And experience, the article inherits the previous chapter content.


#1201

What do you mean by extra additions?

Also sometimes when I add a new item into the game with a new icon some
graphical bug happens where I open the menu and it has a competely different
icon. And I can keep opening it and changing screen and it can change icons.


#1202

How do I change my party members around (add characters and take them away with events)


#1203

Through events, there is a tab on the left called unit placer.
You go through that menu to decide what you want them to do.
Like you can load units to the map and make them instantly join you if they are a player etc…
Or the Unit Placer Tab on the Home screen lets you edit units entering the map through player or enemy or reinforcements, but they still need to be loaded Via event.


#1204

I was specifically asking about how to do things such as make characters leave the party, or join after a level is finished.


#1205

more errors to report. This time the tile changes are very bugged out

Earlier when messing with tile changes and occasionally the changes would cross (a chest would appear inside a destroyed village) for changes within the same chapter and I wouldn’t be able to change this even if I re-pointed it.
I temporarily solved the problem by changing the data pointer- but there was always 1 or two chapter this would happen in.


#1206

to leave the party, when you are in the events and the Show All Tab, just search for unit erase.
There should be one without sound, and one with sound.

To Join the party, I just add them via Unit Placer before the preparation screen.


#1207

Perhaps I think that you misplaced the map change (tile change) PLIST.

Is the correct value written in the PLIST of tile change of ch 9?
Did you mistake this, have you written PLIST ID such as palette, tile animation, map pointer?

If you make a mistake, data such as pallets will be interpreted as tile change data, and a lot of errors will be displayed.

If the pointer is correct, is the termination data correctly included in the map change data?


Normally, when Reload is performed by incrementing the number of tile changes by 1, the terminating data is displayed.
0xFF is the terminal mark.
How is it set in your ch 9?

Summary,
First of all, please check whether the PLIST of map change (tile change) of ch 9 is correct.
Make a mistake and check whether you have set other PLIST such as pallet.

If the PLIST is correct, please confirm that the termination data (0xFF) is correctly set with the tile change data at the pointer tip.

If that does not work, please give me an ups file.


#1208

The way to exchange parties is different depending on each case.

1. When you want to make a unit a join your party.

In Unit Placer, assign the player as a member and place the unit.
And read the unit with the following command.
If the character is not at your party, join the party.

402C0100XXXXXXXX20300000 Load units and Move, If Player Unit,Join your party[XXXXXXXX:POINTER_UNIT:Units](LOAD1+ENUN) {LOADUNIT}

2. When you want to change from enemy army to Player party under certain conditions.

For example, in a talking event etc., it is a case to convince an enemy army and add it to a player’s party.

This will create an event for the conversation and change the affiliation of the unit with the following instructions.

2234XXXX	[XXXX:UNIT:Character]changed to Player(CUSA)	{UNITPERSOLNAL}
2434XXXX	[XXXX:UNIT:Character]changed to Enemy(CUSE)	{UNITPERSOLNAL}
2334XXXX	[XXXX:UNIT:Character]changed to Ally(CUSN)	{UNITPERSOLNAL}

3. If you want to temporarily remove the unit from the party.

Temporarily detach the unit from the party and use it for events such as reuniting with the unit in the latter chapter.
The character of Departure flag On disappears from the menu.

2034XXXX	[XXXX:UNIT:Character]Departure flag On data remains, but it disappears on game(REMU)	{UNITPERSOLNAL}

2F34XXXX	[XXXX:UNIT:Character]Departure flag off will be visible on game(DISA)	{UNITPERSOLNAL}
Or
2134XXXX	Changed to be able to join[XXXX:UNIT:Character]as a party(REVEAL)	{UNITPERSOLNAL}

4. Switch party.

Sorry, I do not understand this because I have never used it.

Oh, the translation of the instruction is misinterpreted.
I’ll fix it later.
The former is Ephraim and the latter is Eirika.

400D000015640808	Party switch diaphragm	{WMAP}	{U}
400D000065640808	Party switching Eliq	{WMAP}	{U}

400D0000 (ASMC) is an instruction to call asm code.
The function to be called is little-endianed and -1.

400D000015640808 -> 15640808 -> 08086415 -> 08086414 (Call ASM function 08086414)
400D000065640808 -> 08086465 -> 08086465 -> 08086464 (Call ASM function 08086464)

#1209

Please explain in more detail what something “extra additions” points.

For example, are kaitou patch or TLP like the extra stage?
This is the same as normal stage movement.

To end the game, use epilogue save.
Then, at the end of the event, -FIN- will be displayed and the game will end.

So, if you do not call this command, The game will continue.

242AXXXX Epilogue SaveXXXX::Value 1 {ENDING}

Credits and turn numbers can be called at any time with the following instructions.
Because I think that you used FE8CN, it will be towards {J}.

400D000031960C08	Endgame Credits	{ENDING}	{J}
400D000079480C08	Endgame Credits	{ENDING}	{U}
400D000041D00B08	Display total number of turns of ending	{ENDING}	{J}
400D000075810B08	Display total number of turns of ending	{ENDING}	{U}
400D0000D5B70B08	Ending's battle display	{ENDING}	{J}
400D0000956C0B08	Ending's battle display	{ENDING}	{U}

After displaying these, if you move the stage normally, it seems to the user that you moved to the omake stage after ending.

In addition, by setting the global flag, it is also possible to produce events such as events occur when visiting the port after ending.


#1210

Look at the picture, I added a character in the sequence, but he disappeared in the next chapter, but he was able to see it in the army, but he didn’t show up.
I try to add him in the next chapter, but it will not end my sequence.
Do you want to add something to the end of the event?


#1211

I think probably that the withdrawal flag (REMU) became effective somewhere.
Issue an instruction to release the withdrawal flag.(DISA or REVEAL)

2034XXXX [XXXX:UNIT:Character]Departure flag On data remains, but it disappears on game(REMU) {UNITPERSOLNAL}

2F34XXXX [XXXX:UNIT:Character]Departure flag off will be visible on game(DISA) {UNITPERSOLNAL}
Or
2134XXXX Changed to be able to join[XXXX:UNIT:Character]as a party(REVEAL) {UNITPERSOLNAL}

If this is not enough, please use the unit placer, load that character as player army in the
start event.


#1212

For FE8 is there an easier way to change chapter titles?

I’ve followed that guide to the T, and got everything the way he had it. Only when I load ingame the titles palette is all messed up and not the correct colors.


#1213

Apply the “Chapter names as text” patch, then you can just edit the text for each chapter name.


#1214

Unfortunately this is what I get when I try. This message also appears for some other patches and I have zero idea what it means or how i fix.


#1215

What version of EA do you have? It might be outdated. The current version should be around v11 or so.