FE_Builder_GBA


#1053

Sometimes this happens to me but when I restart my computer FEBuilder is able to access the server again (the issue may be specific to users like me who run windows virtually). Have you tried that?


#1054

Does that mean that the first access works well?
Perhaps, there may be a problem with the part of camouflaging chrome’s UA.

In the part that accesses all the Web sites, we are faking chrome’s UA ,so as not to have distrust from the partner’s site.
At that time, random elements are added.
Specifically, the minor version is obtained as a random number.

This may be counterproductive.

I modified this routine with the latest version.(ver.20180408.13)


#1055

I found something peculiar. In the text editor any text after a ‘@’ gets deleted.

I guess this is because @ is used to denote functions and commands, but it’s quite inconvenient. At least for my previous hack, since FE7 doesn’t have special characters such as “¿”, “¡”, “ñ”, “Ñ” and the vowels with accent mark. I replaced the least used symbols for those characters, in this case, @ = ó.
Is there a way to put a @ in the text editor?

But I don’t think this is a huge problem, FE7 is now less popular than FE8 and only non-English speakers require special characters, which are already in FE8.


#1056

Where should I look at if I want to increase the supply convoy above 100?


#1057

Transport corpus data is saved in save data, so there is no choice but to remodel the saved data.

For FE8U, please use break_save patch.
Increase the status of units from 31 to 61,
And will increase the transport team from 100 to 200.

However,
Since save data is remodeled, it will not be compatible with existing save data.
Please start a new game.

Also, it can not be used at the same time as remodeling other save data, such as making the class displayable up to 0xff.
However, as a result of mutual concession, you can coexist with skill patches.(skill systems)


#1058

I corresponded with the latest version. 20180411.19

After updating the version, it becomes available.

If you want to display atmark, please write @0040.
In case of FEditorAdv notation, please set it to [@].



#1059

Dear Mr. 7743, in terms of skills, I have set skills for my career and he doesn’t seem to be effective. Can you tell me how these skills will work for him?


#1060

FE8J’s skill system was made by aera.
I am not familiar with the skill system.


#1061

This skill seems to be able to react once only after destroying the enemy.

敵撃破後に1度だけ再行動
Re-act once after enemy defeat

In the Japanese version, it seems to be working properly.
I asked a person using that skill.
It seems to work correctly in Japanese version.

If it is a Chinese version, it may be something wrong.


#1062

Oh, so he can’t work in the Chinese version. I hope he can improve the Chinese version.


#1063

这个“技能”正常运行
This “skill” runs normally


#1064

So, I don’t know if anyone else is facing this problem, but the extend list button for the class editor is gone.

It seems to persist between games


#1065

I hidden the class extension button.
For detailed reasons please read about 16,17 days ago.

Class expansion causes various problems.
And there is not yet a complete patch to fix it.


#1066

ah, I see.


#1067

…Why not just assign them to the same bytes as FE8 does?


#1068

It is for historical reasons.

If you want to use “@” itself, write @0040,
Or
When using FEditorAdv notation, please write it as [@].

To understand why this happened,
I have to tell the history of remodeling FE Tool in Japan.

FEditorAdv did not correspond to Japanese ROM.
Therefore, another software was created in the Japanese version.
That is FE7Edit.

I think that FE7Edit is the first using character escape code “@”.
FE7Edit is a software to change the text of FE6, FE7J, FE8J.

After that, after FE7Edit, software called Projects_FE_GBA was created.
With Project_FE_GBA, all items except images were able to be changed with the GUI.

Nightmare did not correspond to Japanese ROM, we used the structure function of the hex editor called strling.
With Projects_FE_GBA, we can modify the values in the GUI and you can also modify the text.
With Projects_FE_GBA, all items except images were able to be changed with the GUI.

FEBuilderGBA was made with reference to Projects_FE_GBA.

FE7Edit (Text Escape @)

->Projects_FE_GBA

->FEBuilderGBA

FEditorAdv, after that, a patch to support image replacement was created for Japanese ROM.
However, string substitution was not supported.
It was support only for changing portraits and battle animation.

Also, the person who made the patch has left.
I was maintaining Japanese FEditor.
At that time, I was consulted about importing animation and crashing.
I had trouble modifying the source code of FEidtorAdv.

Just then, Maintenance of Projects_FE_GBA ceased.
World map event correspondence etc are no longer done at all.
Projects_FE_GBA is not open source, source code was not disclosed.
It was written at VB.net, IL decompiling was also difficult.
Also, because it was written at VB.net, the behavior was not so early.
Also, since images are not supported, it was necessary to use multiple tools.

So, I decided to make a new tool.
That is FEBuilderGBA.

I’d like to compare it with screenshots.

FE7Edit
In FE7Edit, we were able to change only serifs and items.
“@” Is used for character escape.

Projects_FE_GBA
In Projects_FE_GBA, in addition to serifs, most of the changes other than images were made.

Character editor

Battle animation

FEBuilderGBA
FEBuilderGBA supported images and various functions with reference to the screen of Projects_FE_GBA.

Character editor

Battle animation


#1069

A function for debugging was added.(ver:20180420.22)
Connect to the active emulator and display the event or Procs in operation.

This function is implemented by forcibly scanning with the ReadProcessMemory API of the memory of the emulator in operation.
Therefore, most emulators can be supported.
However, I am afraid of memory protection by OS and competition with anti-virus software.
I am testing with VBA-M and mGBA using win7 64bit OS.
(It also worked on Win10).

In request to use this function, it is necessary to start the emulator from FEBuilderGBA.
Normally, pressing the F5 key activates the emulator.
Then select “Menu” by “Tools” -> “Connect to active Emulator”.

This will scan the memory of the emulator in 1 second increments and display the information on the screen.
(By changing the Setting “Automatic connection to the emulator”, you can connect automatically when starting up the emulator.)

If the event is running, it displays the currently executed event.
The place where the cursor is located is currently being executed.
The observed event is recorded in the event history.

If you are interested in Procs, you can see the details on the Procs screen.
Double click on Procs to see the more information.


I made reference to Stan’s document to make this function.
Thank you for publishing detailed materials.

If you want to ease to debug the game, you can use the cheat function.

You can clear the chapter by setting the stage clear flag 0x03 and waiting for the unit.(skip chaptor)
You make the selected unit strongest,
You can make a character moribund or have a specific item.
And can increase your money and change the fog level.


I hope that this function can help you create your game.

Currently known problems.
Sometimes it’s time to disconnect from the emulator.
After a while, it will automatically restore.
If you do not want automatic recovery, restart the emulator.
This is probably because the memory page of the emulator was moved by the OS.
Although it is trying to track automatically, for some reason, there are times when it does not work properly.


#1070

How do you level up units to a certain level, like for example, I want my units to have random lvl ups. The same as enemies. Say I have Elen, from FE6, her bases are at level 2 but, I want her to be at level 10 when I get her with her own growth rates. Like an enemy unit grow as they lvl. Is there a way or is it just enemies?


#1071

How do you level up units to a certain level

I am rewriting the information of the unit in RAM.
See the CHEAT_UNIT_GROW_Click method in EmulatorMemoryForm.cs for details.

For the structure of RAM, see the “@Unit” part of config/data/asmmap*.txt.


#1072

I fixed some bugs.(ver 20180421.09)

I did not consider the possibility that the RAM pointer rather than the ROM pointer would be written to the address referenced by the emulator.
When RAM Pointer was written, it recognized that an abnormal value was written, and it disconnected by mistake.