FE_Builder_GBA


#1032

I’ve done that before, and I’m sure that would work, but the issue is that for this project I’m going to be adding in quite a bit of new items.


#1033

Ah I see. I’ll take a closer look into icon expansion then, sorry~


#1034

It’s all good!


#1035

Hey, I updated to version 20180401.04 of FEBuilderGBA, and I’ve noticed a problem whenever I try to change the setting “Search starting position at ROM expansion”. It defaults to option 1 (1=0x09000000 or later 0x00 is 8192 continuous), but no matter what setting I change it to, whenever I click save and go back in to check if it’s changed, it remains on setting 1.

This happens no matter what ROM I open up inside FEBuilderGBA.


#1036

This is a bug.
I fixed it with the latest version.(20180401.11)


#1037

I expand the icon correctly in my environment.

I adapted an icon expansion patch.
Increase icon to 0xFE.

Extend the icon table.

Set an appropriate icon on icon 0xFE.

I set the rapier icon to 0xFE in item setting.

When I start the game, the icon me set is displayed.


#1039

Hello 7743, I corrected the translation of FEBuilderGBA.
(FEBuilderGBA_20180403.23)
https://pan.baidu.com/s/1LGdjgoEYxTynWXwCu1MrQg


#1040

I found an error


Some fonts will become garbled

such as : 爪→ ý, 吉→ ˆÿ


#1041

Thank you.
But, will you send me a compressed file of it?

Without buidu’s software, it seems that it can not be downloaded at once.
Although it can download if it is a single file, it seems that special software is required to compress the tributaries and download them all at once.
I do not want to put other software into the development environment if possible.

Please compress the file and send it in rar or zip, 7z format.


#1042

Some fonts will become garbled
such as : 爪→ ý, 吉→ ˆÿ

I think that it is a character placed in the same area as the Unicode area represented by single byte of FE8U.
It is the same problem as the Japanese half-width katakana area.
I will fix it next time.


#1043

https://pan.baidu.com/s/1BT4KWhwcFhtEDAgKhv53Xw


#1044

Merged with the latest version. (20180406.23)
Also fixed a bug in “爪→ ý, 吉→ ˆÿ”.


#1045

Added information can be retained.(20180406.23)
This allows you to do the following three things.

You can turn off excessive error notation individually (on an address basis).

You can now write comments on the event.

The comment you wrote at the top address is also the name of this event.

You can now set names for flags.

These information are saved as external data when saving the ROM.
The storage location is the following place.
FEBuilderGBA/config/etc/ROMNAME/*.txt


#1046

Each time I try to update FEBuilderGBA via the welcome screen it gives me this error message

any help? I installed it on this computer just recently.


#1047

Can you access the following web sites?

The error is displayed when you can not connect to the web for updating.

string url = "https://ux.getuploader.com/FE4/";
string contents;
try
{
    contents = U.HttpGet(url);
}
catch (Exception e)
{
#if DEBUG
    R.Error("web access error!", url, e.ToString());
    throw;
#else
    return R.Error("web access error!", url, e.ToString());
#endif
}

#1048

I can connect to https://ux.getuploader.com/FE4/ just fine


#1049

If you can access the site with a browser, I think I can access FEBuilderGBA too.
I forget to give a detailed error message.
In the latest version, I made a more detailed error. (ver. 20180407.18)

You will be downloading manually because automatic update is not available due to errors, but will not you download the latest version from this site and try it out?


#1050

alright, i’ll download the latest version now

EDIT: installed the latest version and tried to update

The remote server returned an error: (503) Server is not available.
  in System.Net.HttpWebRequest.GetResponse()
  in FEBuilderGBA.U.HttpGet(String url, String referer)
  in FEBuilderGBA.UpdateCheck.CheckUpdateURL(String& out_url, String& out_version)

#1051

According to the error message, it seems that the server could not access it because it returned a 503 error.
I saw this server returning a 503 error for the first time.
Is it because it is accessed from abroad?

but, I am not a manager of this server, so I can not do anything.
(This server is a shared server used by Japan 's modified remodel FE Community.)

If errors appear many times, there is no choice but to change the server…


#1052

I see. Also, this error has occured multiple times before, it’s just I decided to report it only now (I’ve been updating FEBuilderGBA manually for all this time).

You don’t exactly need to to change the server, I can keep updating manually.