FE_Builder_GBA


#991

That is not a problem of ROM, it is a problem of environment to operate.

When executing EA, FEBuilderGBA defines free space to avoid accidents.

ORG FREESPACE
include EA.evet

To insert the ORG command, create a temporary file.
Since I can not define the definition of FREESPACE with the option of Core.exe, I need to create a temporary file.

This error occurs if EA(Core.exe) can not access this temporary file for any reason.

I tried a little adjustment with the latest version.
When I passed a temporary file to EA, it was a relative path, so I changed it to absolute path.


#992

It appears that I can’t install any patches anymore.
Tested to install the C01, C48 and Anti-Huffman Patches with FE7U and FE8U. Both were clean ROMs. I get an error and FEBuilder crashes.
I used the most recent version of it.


#993

This is a bug.
I fixed a bug with the latest version.(20180327.05)

The reason is the story of the program code.

When hints are issued with disassembler etc, in order to give more hints, I must do a deep search.
Because it takes time to conduct a deep search every time, I have kept only the simplified information until now.

From this version, I searched for information and threaded it behind, because I could not make deep information without taking more time.
However, when patches were applied, I had to search again.
At this time, I had forgotten to stop(join) if the thread was still searching.


#994

Wow that was fast!
It works like a charm now. Thank you very much 7743 :smiley:


#995

Bug i found when I installed the Class Expansion Patch on a fresh rom.


#996

Seth’s res stat was 8, but when I suspend, and resume chapter, his res went to 24.


#997

Did you apply the Class Expansion patch?
Because that patch is unstable and makes bugs like that.


#998

Yes. And on a fresh rom.


#999

So the patch is not usable?


#1000

Read this:

And don’t make multiple post, make your replies in a single post.


#1001

I used Febuilder to install it.


#1002

Oh ok. Thank you for the info.


#1003

I think that classes should not be extended.
Extension of class causes various problems.

There are some patches to fix it, but it is still hard to make it work perfectly.

I think that the merit obtained when expanding the class and the risk that occurs when extending the class are not now balanced.
There are too many risks.

If you absolutely want to class extend, I can not stop it.
However, You have to fight with various problems.

The save data extension of FEBuilderGBA “class_fix” is based on the script of kirb.
Something might be wrong with this script.

But I can not do anything.
It is difficult to support because I did not make it.

I made a strong warning when expanding the class.
Still, some people are experiencing trouble by extending the class.

I would like to consider hiding class expansion buttons by default…


#1004

Oh ok I understand thank you for the reply.


#1005

So its better not to use the patch. Ok.


#1006

Dear Mr. 7743, I have placed some characters on the map, but some characters can’t appear. What have I done wrong?


#1007

There are plenty of enemies on your map, but have not exceeded the maximum number that can appear at the same time?

In FE 8, enemies can only appear up to 50 (0x32).

//Work memory.
0202BE48 @Unit@[3E] Player {J}
0202CFB8 @Unit@[32] Enemy {J}
0202DDC8 @Unit@[14] Ally {J}

0202BE4C @Unit@[3E] Player {U}
0202CFBC @Unit@[32] Enemy {U}
0202DDCC @Unit@[14] Ally {U}

If this is not exceeded, is it the specification of the instruction to load?
However, I have done quite a lot of enemies at the same time with the kaitou patch.
It worked correctly.

If it does not exceed the maximum number.
Since there are several instructions to load, how do you change it or try loading it in split?


#1008

Yes, I already reported this. We actually know a lot more about it now. It’s related to the deployment order of units.

@Kirb is, hopefully, working on a fix.


#1009

Oh, that was my mistake. I didn’t know that there were fifty enemies at the same time. I placed far more than fifty enemies.


#1010

When editing fe7, I noticed that it asks you to patch a class extension patch, and an item icon extension patch if you want to increase the amount for those categories.

Such as if I want to make more classes it asks for me to use the class extension patch.

However I am unable to find these patches in the patch list, am I missing something?