FE_Builder_GBA


#971

This “LevelUP” image is used when you gain a level and animations are off. I don’t know where is the normal “LevelUp” yet.
However, how did you replace the image?
When I click on “Import Image”, I cannot choose an image because there is no window opening up.


#972

This “LevelUP” image is used when you gain a level and animations are off. I don’t know where is the normal “LevelUp” yet.

i see.

When I click on “Import Image”, I cannot choose an image because there is no window opening up.

Have you updated the version of FEBuilderGBA?
The latest version is the following version.
FEBuilderGBA Version:20180324.11

This is a Japanese version ROM, but inserting images works.
It also worked in games.
There seems to be a problem of the palette and the length of the character string, but it works.


I could insert it even in FE6FR.


#973

Just some thoughts that might help resolve this: Have you tried inserting this with a different graphics modifying tool? Did you insert it into your FE7 ROM with FEB? Is the battle screen image accurate when inserted outside of FEB/into FE7 or does it still have bugs? Might be useful info to help 7743 understand the issue better.


#974

I’m very sorry. I don’t understand programming, so I might not be able to help.


#975

Yes I even redownloaded FEBuilder and I still have the issue.
I recorded a quick video to show what happens

Edit : I’m only noticing now but why are your image adresses different than mine?


#976

About battle screen.

I understood the essence of the problem.
I am mistaking the calculation of the tile’s default size.
This problem was fixed in the latest version(20180325.07).

There was not an unusable tile,
but the size of the tile was presented an extra two tiles.

I thought that the size of the name and item tiles were all 128 (16 * 8).
But this was a mistake.

The size of the name and item tile is different.
The size is also different depending on the series of FE.

Name on the left.
The size is not 128, 112 (14 * 8) is the correct number.

Item on the left.
This tile is 128(16 * 8).

Name on the Right.
The size is not 128, 112 (14 * 8) is the correct number.

Item on the Right.
This tile is 128(16 * 8).

Since these tiles are compressed with lz77,
When displaying, you can calculate the size automatically from the compressed size.

However, when importing / exporting each tile separately, I specified the size.
This specified number was incorrect.

Therefore, if you import / export a tile, more tiles than usual will be imported.
This became an unusable tile, and it appeared.
I’m sorry.

Do you have a backup before changing battle screen?
If you have a backup, it is best to start over there.


#977

On the problem of graphic tool import.
Error message is outputted in the latest version(20180325.07).
Can you update to the latest version and send me an error message?

For now, there are three reasons why such a situation occurs.
In order to narrow down the condition, an error message is necessary.

Also, I changed the method of processing slightly.
Until now, when I pressed Import from the graphic tool, I created a temporary file.
I canceled this process.
(I can not reproduce this error, so I do not know if this fix is effective.)


#978

Hi, 7743. Is it possible to add the ability to expand the tables in the Monster Spawn Rates and Monster Item Rates tools? Thank you.


#979

I updated to the latest version. However, I do not have any error message. And this situation happens both on my desktop PC and my laptop so I don’t know what is wrong :confused:


#980

Do you get an error message?
I do not know the cause.
There is one thing I want you to check.

Can You copy the directory containing FEBuilderGBA to a directory such as c:\temp

There was a problem that automatic update failed if there was a French directory before.
It may be a similar problem.

Can you see the patch screen with FEBuilderGBA’s Menu Tool-> Patch?

In the graphic tool of FEBuilderGBA, if you select Import, you create a patch of the displayed image and edit the image by executing that patch.
Perhaps it is not possible to display the patch screen for some reason.
Can you open the Tool->Patch screen directly?

Can you download FEBuilderGBA again?

The FEBuilderGBA update is basically only an addition.
It does not delete.

Perhaps there is data in the config/patch2 directory of your FEBuilderGBA that causes some problems.

Would you please try downloading the latest version directly from the server and trying to reproduce the problem?

If (2) works well.
I made the patch to change the image of LevelUp with the latest version.(20180325.11)

It is a patch with the following name.
“Image of LevelUp(Only when turning off battle animation)”
With this patch you should be able to change it without using the Graphics tool.


#981

I installed the expansion button with the latest version.(20180325.11).

I set zombies to assign extended DropItem table 0xFD and drop Master Seal with a probability of 95%.
This seems to be working.

Along with that,I changed the UI a bit.
The biggest change is that I started the item and probability table from 0x00.(NULL TABLE)
0x00 always requires 0 data.
Until now, I have skipped the display.
However, in order to expand the table, since 0x00 value must also be displayed, it is displayed from this time.

Since this function has not been fully tested yet, try up after taking a backup.


#982

Well, I can start over again since I haven’t fully started to import everything from my old hack to FE8.
I’m waiting for the Str/Mag split patch. In the meantime I’m experimenting with your tool.

Thanks for the help, I’ll report any other issue if I find one.


#983

@Yami, did you figure out what was causing this? I am having a similar problem. I have Seth set to a custom class in the expanded table, which works as intended until I reset the ROM and load the save file. After that, he changes to an Ephraim Great Lord class every time.


#984

I don’t get an error message sadly.
This situation only occurs in the Graphic Editor tool. For exemple, in the Chapter Title editor, I’m able to import just fine.

I did all of your 3 steps. (2) works well; however there are many other images that would need to be edited. They cannot be edited in any other tool of FEBuilder.

Thank you for all your hard work.


#985

The glitch does occur when you suspend the game and then restart the chapter.


#986

Sadly, not yet. Been tinkering with it when I can but it’s been a pretty busy week.


#987

It may have been able to correct the problem with the latest version.(20180326.00)

Since there was a similar phenomenon in the Japanese community, I asked the test to cooperate.
As a result, it turned out that there was some problem with the routine implementation method.
I changed the implementation method of the routine.

I do not quite understand the direct cause,
If it interferes with multiple forms at the same time in C# in a short time, problems may occur in some environments.

I hope that it will work properly even in your environment.


#988

What happens when the game is interrupted means that,

It seems that the patch that extends the save data is not correctly adapted.

Suspending and restoring games save and read data like save and load.
(However, the interruption and save routines are different.)

Normally, in GBAFE, the class seems to be stored in 7 bits,.
You can not store 0x80 or higher classes unless the save data is extended.

When extending the class structure, it causes various problems, so I recommend that it does not expand .
We can not extend our class unless we solve various problems.
I do not think the merit of extending a class is worth the risk.


#989

It works correctly now. Great job and thank you again! :smiley:


#990

Apparently a file is missing in the Class Expansion patch for FE8

EDIT:
I used a clean ROM and it didn’t have any problems. Odd…