FE_Builder_GBA


#931

So I was making a rom hack using fe builder, and it was going well until this recent update. it would expand my battle animation fourfold with blank battle animations with random text, and when I correct the number to the none blank animations, it removes all the portraits in the game. I’ve tried using backups and even reinstalling fe builder, but this problem still persists.


#932

I think it is a serious problem.
Please send me an ups patch.
I want to reproduce the problem.

And please explain in detail how to reproduce.


#933

Wow, just tried FEBuilder for the first time and, huh, it’s the greatest tool I’ve ever seen. Keep up the great job!


#934

https://drive.google.com/file/d/1bcyh66g9Rbz9hZrsQ2un8yJ1f9t1Kn-Z/view?usp=drivesdk

You really just have to go to battle animations, and it causes the problem


#935

Is there a backup just before it gets broken?
And, how do I want to know how to break down.

Also, I could not open ups file.
This ups does not seem to be made from fe8U.


#936

From the data 0x10 0x00 0x20 0x00, what can be inferred is that,
Some compressed data may have been written in this area.

This is because FE lz 77 starts with a start header of 0x10.
And write 3 byte size.

There is a possibility that an image or something of 0x00 + (0x20 << 8) + (0x00 << 16) = 0x2000 bytes has been written in this area.
there is also possibility of other data.

Please send me the ups file obtained from FE8U and the ups file of backup before breaking.
Please send me two files.

I would like to examine this written data,
The most important thing, I want to reproduce how to break.


#937

It seems now some of the backups are bugged, they are .7z files but contain nothing, so this backup was created about February 25, and is the latest one I have that is not bugged: https://drive.google.com/file/d/1DpUXlXj-reQSB2cpxjeyayXH931jJN_8/view?usp=sharing

some features are left out in this version from the one I shared previously


#938

work plsups.ups opened correctly.
How can I reproduce bugs from this version?

The latest version of BorsPME.ups file itself is damaged.

This file is not acquired from FE8U or other unmodified FE.
The CRC file that became the original file is different.

You are getting the UPS difference from the wrong file.
Therefore, I can not open BorsPME.ups.

Please create the ups file again and send it to me again.


#939
  1. It all started to happen when I began to edit a class called “Blade Pupil” a trainee class, first with animations and it’s promotion branches, it uses the female theif animation from fe6 which may be significant

  2. Here you go:

https://drive.google.com/file/d/1YoIU7DHgRbyrFwVL1xj5tRhAV_F3hnhK/view?usp=sharing

This should work, I hope


#940

I think a little of what I said got lost in translation at the end. Looking real good so far though! Thanks.

“Item” circled here in the “Item Editor” just needs to be “Icon”. Currently I cannot change this because it shares a text address with “Item Icon”.

I can’t figure out what “QS” in this selection means:

:VBA-MでQSすると、自動ジャンプ
QS in VBA-M, automatic jump

Also I am unable to locate Ability (:特性) 1,2,3,4 tooltip text for editing in the Character Editor within en.txt. :slight_smile:

I’ve done another translation. Please update with this version: https://www.dropbox.com/s/4tv6xam06ouv7st/en.txt?dl=0


#941

Thank you for sending the data.
I analyzed the data and found some problems.

I may not be able to completely remove the error from this ROM.
I’m sorry, could you redo from the last backup in February?

For individual problems, we have taken measures at the latest version.
(It was fixed in ver 20180320.20.)
However, there are still other problems with this ROM.

On the reason why abnormal data number is displayed in battle animation.
The cause is caused by I being halfway compliant with FEditor’s Hint Length.

FEditor writes the number of data to the table outside the table (table address - 0x4).
FEBuilderGBA used this value if it had this value.
In some Hack ROMs, invalid data may be inserted in the middle.
In that case, the search routine of FEBuilderGBA to continue searching until an invalid value comes up is because we could not find the termination data of battle animation because of invalid data sandwiched in the middle.

Therefore, if there was a hint on the number of data of FEEditor, it was referring.

However, its value is 4 byte number,
And it is written out of the table (table address - 0x4).
Therefore, I do not know if this value is a reliable value.

Ignored if it was a strange value (0xFFFF or more).
However, this time happened to be less than that value,
but this problem occurred because quite a large number of data was written.

As a result, searching for data beyond the end of the data was executed.

I do not know why a large value was written.
Originally, the address outside the table (table address -4) is outside the frame, so there is a possibility that another data may be written.
I should not use this address.

I would like to avoid using the FEEditor’s hint area anymore.
Since it will be necessary when opening a Hack ROM created before, I will have it in the option.
As this may cause problems, turn it OFF by default.
As a result, the search for an abnormal number of data will no longer occur.

About data securing logic.
I am changing it in March.
It works properly in my test environment, but this may be related to something.
I definitely want to secure safety, so I think I will return to the logic before this.

When data was placed at the end of the ROM, we modified it so that you do not have to reserve it when resizing the data.
This routine saves ROM size.
However, this may cause something bad results.
Once I cancel this fix.

About problems that can not be backed up.
Here too, it is correct in my test environment.

However, we are revising it in the second half of February.
There was a problem that the archive library you use does not work properly if there is a directory written in French.
Therefore, in order to avoid directories written in French, we changed to routines to get from absolute path routines, if possible, relative paths.
This may be the cause.

I did not take into account the possibility of the compression routine failing during backup.

If backup data can not be compressed with relative path, I decided to try compression with absolute path.
If it fails even with an absolute path, I saved the data as uncompressed.

Also, if it does not work, in addition to the condition that the compressed file was not created when an error is returned,
Under the additional condition, if an abnormally small file of 1 k bytes or less is created, it is treated as an error.

With this fix, I believe it will not occur anymore.

About another problem of this ROM
There is data that the frame data was damaged around the time of the battle animation.
Also, when you start with NewGame, it freezes at the world map start event.

After chasing with the debugger, it is falling with the following order.
60C300000000010000000000

However, there is no strange thing about this order and its order.
Looking at the arguments when the 60C3 (C360) instruction is invoked, there is a difference in work memory arguments.

ROM with bug
r0 2025600
r1 800cc19

vanilla ROM
r0 202566C
r1 800cc19

I do not know why this work ROM has different work memory.
I am not confident that I can solve this bug.

So, I am sorry to you, will not you do it again from the backup in February?


#942

Also I am unable to locate Ability (:特性) 1,2,3,4 tooltip text for editing in the Character Editor within en.txt.

The check boxes of “Ability 1”, “2”, “3”, “4” of items are in the following text file.
/config/data/item_checkbox_FE8.en.txt
/config/data/item_checkbox_FE7.en.txt
/config/data/item_checkbox_FE6.en.txt

The check boxes of “Ability” used in units and classes are the following text files.
/config/data/unitclass_checkbox_FE8.en.txt
/config/data/unitclass_checkbox_FE7.en.txt
/config/data/unitclass_checkbox_FE6.en.txt

I can’t figure out what “QS” in this selection means:

It stands for “Quick Save”.
That is a function that you can save anywhere by pressing Shift + F1 in the emulator.

We call this function “State Save” or “Quick Save”.
We abbreviated “Quick Save”, shortened QS,and “Quick Load”, and call it QL.

“Item” circled here in the “Item Editor” just needs to be “Icon”. Currently I cannot change this because it shares a text address with “Item Icon”.

Japanese names are icons (アイコン).
Perhaps because the translators wanted the “icon” part of the detail menu to be “item”.

I would like to change the details menu to an “item icon”.

In this way, I can release the character string “icon”,
so I will change that name to icon, which is its original meaning.

The next time, I will change it.


#943

Thank you for your help, and I think I can rmake it from the February backup. This has been very informative.


#944

With the latest version of FEbuilderGBA, please check that your backup can be taken correctly in your environment.

I have fixed an error that I can not back up.
However, if I do not have a backup, I will repeat the same mistake again.

First of all, I’d like you to confirm that backups are performed correctly in your environment.

If you overwrite it after writing the data, backup will be created with 7z.
Please check if backup of 7z is acquired.


#945

https://pan.baidu.com/s/1pgn6-FN7x5FJhxcDveyAew
Hello 7743, I will continue to translate later


#946

Thank you.
Merge in the next version.


#947

Thanks! The backups work again.


#948

I merged the translation data with the latest version.


#949

I merged the translation data with the latest version.
I also fixed string the “icon” of “Item Editor”.


#950

Thank you for checking the backup operation.