FE_Builder_GBA


#730

I think the point is that the “extending health cap” patch isn’t working properly.


#731

Please apply “break save patch”.

For patches such as “HP Limit Player”, change the upper limit value.
However, it does not change the value that can be saved.

If you want to save data, you need to modify the save data format using “break save patch”.

“break save patch” extends the upper limit of the status that can be stored to 63 and the upper limit of HP to 120.
Transportation units will also be expanded to 200.

However, save data will be incompatible, so please destroy the existing saved data of the game after introduction.
This patch has recently been ported, so there may be bugs.
Take a backup and try it carefully.


#732

Cool, but another problem I ran into is that somehow, FEBuilder is only letting me import 3 magic animations. There is a whole list the first time I went in to insert animations, and I inserted 4. However, when I closed out to assign the animations, there is now only the first three. When I return to the insert animation menu, it only shows 3 options, but when I set the count to 4, the 4th one shows up again. However, this does not last and it just goes away again. This was done using the patch that requires EA. The other patch had a glitch when inserting certain animations deletes the chapter data and leaves you with a black square in the corner.


#733

Which magic patch did you use?
FEEditorAdv? CSACreator?

I tried it both, but it works corretly.

Using FE8U, I can register multiple magic using both magic systems.
And it will work correctly in the game.


The problem does not reproduce.

Please describe in detail how to reproduce.

Which magic system did you install?
What magic did you register?
Which magic was the problem?
Can you reproduce it again from vanilla?


#734

I forgot which magic system require you to instal EA, but the one that did had Meteor, Bolganone, Aqua Edge and Excalibur for the spells animation list from here. The glitch the delete the chapter data happened with the other magic system, and I was entering every magic animation, but I think it occured after I entered too many oversized animations. I had not done this on a vanilla rom, but a modded one. However, I can provide a before and after ups patch of them.
This is before the magic animations were inserted: http://www.mediafire.com/file/imcl4lulzg835j1/FE8%20Chaos%20Mode%20before%20magic%20animation.ups
This is after:
http://www.mediafire.com/file/yaz3s7dlaa7cigc/FE8%20Chaos%20Mode%20after%20modded%20files.ups


#735

Thank you for ups.

The reason that only three are available is because data other than the pointer is written in the pointer list of the additional magic.
Data of 0x01 00 00 00 is written in the 4th magic.

Therefore, if a pointer or anything other than zero appears, by the end rule of the list,
This data was regarded as terminating data.

I do not know the reason why this value was written yet.

Did you do something special when writing the 4th magic?
Or did you see any errors?

Do you remember what you tried to import into the 4th magic?

Anyway, You imported the third magic, after that something should have happened.
As a result, this magical value was written.


#736

No, I didn’t do anything different for the 4th magic, I just inputted Bolganone, which I know works because later, I exported it out of the 4th spot and input it into the second.

On a different topic, a few months ago, I asked you about making multiple dragonstones, and you respond with how the stone’s animation are hardcoded and a japanese transformation patch fixes it for the FE8J. I think that Tequilla just released a patch for the english version. Can you confirm this, and if so, tell me how to input it? Tequilla’s instructions are for someone who is experienced with ASM which I am not, so I have no idea have to use it.


#737

I think I found a bug with Song track -> Musical score -> Volume correction. Lowering the value only affects the right audio channel. Here’s an example of what happens when it is used:


As you can see, I tried to lower the volume on that very loud song and it only affected one audio channel.


#738

Hey so I feel like an idiot for asking this but how come I get a stop screen whenever I write the skill patch onto the rom and proceed into a battle animation?


#739

Also How come nightmare doesnt pick up the febuilder changes?


#740

Nightmare and FEBuilder are two completely different programs. If FEBuilder repointed a table, the Nightmare module isn’t magically going to know it moved. Personally, I don’t recommend mixing hacking methods. Stick with Nightmare, stick with Builder, don’t go mixing them.


#741

Thanks. Anyway you could help me with the animation problem I’m having?


#742

So then, after adding the third magic, did something special happen?
something should have happened.

I made a hypothesis.
After extending the magic table, was there any further expansion,
Or The magic table was expanded was not the part where huge zeros are lined up?
If so, did not FEBuilder GBA misunderstand that many zeros lined up are empty areas?
I can not reproduce bugs, so we can not prove the hypothesis.
However, I implemented countermeasures based on this hypothesis.
To secure an area where zeros are lined up in large quantities, put 0xFF FF FF FF in the termination data.
I lose 4 bytes, but it is better than accident happens.

It was fixed with ver 20180214.01.

I also supported transformation patches.
However, since the old SkillSystems and work memory are together, it can not be introduced together now.
must update your skill system to the latest version.

Since skill patches are huge patches, updating takes time.
I will correspond later, so please wait.


#743

It was fixed with ver 20180214.01.

The volume is implemented by lowering the value of “VOL”.
However, this seems to be incomplete.

I noticed it while observing the data.
If Velocity is specified, the value of VOL is ignored.
Even if VOL is set to 0, if I specify a value with Velocity, only that sound will be played at that volume.

Velocity is the strength of hitting a keyboard.
In the s file, it is represented by “v”.

I misunderstood that Velocity is relatively determined by the influence of VOL.
As far as I observe, Velocity is absolute.

I change the velocity, not just the VOL.

There was also a bug against PAN change.
This has also been fixed.

Thank you for reporting the bug.


#744

FEBuilderGBA is based on a pointer where the location of the data is written because it is a design that the table is to be extended.
If the table is expanded and the address changes, the position of the pointer will not change.
And , The position of the address is always written in the pointer.

NightMare determines the write location based on the address.
This method has no problem as long as the address is fixed,
but when the table is expanded and the address changes, it causes problems.


#745

I think that the phenomenon does not occur only by installing skill patches.
I think that something has interfered with another patch.
Did not you apply any other patch or change it?


#746

Checked the recent FEbuilder version, did not see an option for DumpALL to dump the Gifs, FEditor format animations, and FEbuilder format animations. Am I missing it?


#747

I did. Would I have to start from scratch with a clean ROM and apply only the skill patch in order to get it to work?


#748

Hey 7743,

fantastic program! This thread has been very helpful in learning how to use it.
However I cant figure out how to enable multiple achievement flags which call different ‘gotonextchapter’ events. Doing so causes a crash.
Any ideas?


#749

Hey 7743, I highly appreciate all the effort that went into this, however I have one issue I feel needs addressing. For personal use I was trying to use FEBuilder’s built in translation function to translate SOHAE for me to play. However in the text editor, you can only translate one text entry at a time, so after two days of translating entries by hand thru machine translation, the discovery of a separate tool that does all of the entries at once in FEBuilder that isn’t located in the Text editor led me to have a shut down inside. If you don’t mind, would it be possible to include a “Translate all text entries” option in the text editor itself?