FE_Builder_GBA


#2149

This seems to be a problem with SkillSystems,
so I will respond once SkillSystems is updated.

However, it takes time to update SkillSystems and is not a fatal bug,
so I want to fix it in the next skillsystems update.


#2150

Added an option to set it automatically so as not to forget to add enemy’s palette.


#2151

The effectiveness rework patch doesn’t work anymore. It claims it needs the Skill System, but when I patch a clean ROM with just Anti-Huffman and the latest Skill System, it still doesn’t work. I’m trying older Skill Systems rn, but I’d rather not have to downgrade my Skill System to use this patch.

Edit: 10/20/2018 is the most recent Skill System that the effectiveness rework patch works on. Please update the patch so that it’s compatible with Skill System patches after 10/20/2018’s patch! That patch is 5 patches old by now


#2152

Hello again! I have a weird glitch to report. After changing the chapter start event, the screen just stays black. I don’t what I did wrong as I copied the codes pretty close to what it’s supposed to be. Here’s my rom’s ups: https://www.mediafire.com/file/udja2udggayxyj1/WIP_Glitch.ups/file

Thanks in advance!


#2153

In FEBuilderGBA, “effectiveness rework” is always off.
In 2018/10/20, I just accidentally turned it on.

Therefore, I releasing a version that turned it off on 2018/10/28.

I do not want to enable patches that will change the data structure significantly.
Also, the area used by “effectiveness rework” is used by FE8J as magic separation.
I do not think that both versions have different data structures.


#2154

Where did you send report7z?
I do not think it has arrived.


#2155

This is because the BL call at 0x0802BB34 is broken.
It has become infinite recursion.

This routine is CheckForLevelUp.
You rewritten this place for some reason, and it caused infinite recursion.

You only sent ups instead of report7z, so I don’t know when the hour was rewritten.


#2156

Hmm. Well I didn’t intentionally change that value. I’ll send a report, if it’s not too late.


#2157

https://www.mediafire.com/file/kottda0n681xbw8/Glitch.report.7z.report.7z/file

Here’s the report7z. Hope it helps. Thanks for all of the time you spend fixing stuff like this!


#2158

https://www.mediafire.com/file/02sz85c9zz75yci/SS+Hack_4-7-19.PATCH.20190408074032.7z

I will send an ups that fixes this problem.

Presumably,you after adapting the grow_mod patch, adapting some conflicting patch, it seems that the grow_mod is destroyed and the pieces remain in the ROM.
With report7z, I could use the diff debug tool, so I could easily get rid of the debris.


#2159

Thank you! I’ll try to keep note of the patches that I adapt from now on.


#2160

I am having an issue with the latest Skill Systems patch. After updating the first chapter of my hack freezes. Could someone please help me with this? Here is the report: https://www.dropbox.com/s/0hwqld028jlm67p/Binding%20Blade%20Remake%20Report.7z?dl=0


#2161

Please uninstall and reinstall “ModularMinimugBox: 2018 Default With Skill”.

Or

If you have a backup before updating SkillSystems,
Update SkillSystems after updating FEBuilderGBA to the latest version.

The SkillSystems Skill_Getter has been updated,
but old FEBuilderGBA is still not making its tracking routine.

The latest version has a routine to find a new Skill_Getter,
so it should be able to update without problems.

I will send you a version of the ups that has been modified to work with “ModularMinimugBox: 2018 Default With Skill”.

https://www.mediafire.com/file/uoo2abnsq6hr9ah/The+Binding+Blade+Remake.PATCH.20190412053507.7z


#2162

How do I edit the menus without completely destroying the pallet? I’m currently trying to switch all blue to red at the least and at the most change all the menus to look different the the generic sacred stones one but whenever I export and image and change it and try to import it the entire image is messed up even if I just change one pixel.


#2163

What does “the menus” mean?
I want to confirm the situation,
please send report7z.


#2164

I’m not sure its a bug or error I think I’m just doing something wrong. By menu’s I mean the stuff like Battle Preview or System Menu, etc. I wanna be able to make those look red and more simple. Same for the player turn pop up and stuff.


#2165

Please send report7z.

I think changing the palette of the system menu will affect various places.
However, I can not answer unless look at the status of your ROM.


#2166

I’m pretty sure it is not an error or anything I would need to report. I all want to do is change the way the menus and stuff look like so everything is generic FE 8 looking.(The battle preview, System menus, etc) but whenever I export the image, change something and then import the image, everything looks weird and the rom is basically corrupted.


#2167

How do you want to do this?



I changed the picture of the menu a little and drew the “/” at the bottom right.
Also, I changed the palette and made it pink and yellow.
This works correctly.

I think you probably broke the TSA structure.
The TSA structure is so complex that I recommend not to change it.

In the screen, the part A is the part that changes the data structure of TSA.
Do not change this part.
The TSA structure of Menu is so complex that changing it usually has disastrous consequences.

There is no problem if you change the part B.
You can change the appearance of the palette by changing it.
This menu has 4 palettes, which can be switched with the C combo box.

By changing the Image, you can change the menu design itself.
However, since it is divided and stored by TSA, changing is quite troublesome.


#2168

so is there no way to make my menus look like Tred or make the player turn look like thisEvil_PlayerPhase