FE_Builder_GBA


#2128

fyi I just now (hopefully) fixed the bug of not clearing after chapter (again) in Skill System master (If that’s a bug didn’t occur in older versions then it was probably my fault, sorry).

(I wouldn’t be surprised for the range issue to be a skill system issue too, as we got a fairly significant item range rework included in relatively recently (@Teraspark)).


#2129

I checked in several versions using a vanilla ROM, and the debuff problem is there from the very first patch in the FEBuilder.


#2130

I want you to use the December version.
For now, please don’t update now.

Since I received your ups, I would like to test the update with the version in this.
I will contact you again when it is able to update correctly.

The range problem is fatal, so I have to identify the problem.


#2131

I understand the cause of the range glitch problem.
This is because “Range Display Fix (EA)” is already installed on your ROM.
Even with the new SkillSystems, there is a conflict due to the implementation of similar functionality.

Fixed the SKillSystems updater to automatically uninstall “Range Display Fix (EA)” if it was installed.
This solves the problem.

If you update to the latest version of FEBuilderGBA, you will be able to update correctly.

However, the debuff issue is still unsolved.
I want to investigate this from now on.


#2133

I made a modified version of Stan’s debuff fix.
Please update FEBuilderGBA to the latest version, update the skillsystems and check the operation.

Skill SkillSystems 20190404

#2134

For some reason the emulator debug tool won’t connect to my VBA-M


#2135

Are you using the sourceforge version?
It does not work with github version.

Or use mGBA.


#2136

Added the function to find free strings without references.


#2137

The debuff problem is solved, but I found another glitch.

When you reset the game in the world map all units disappear.
emulator_01

I’ll send you the report


#2138

This is the problem of old save expansion patch. You should use the lastest patch of stan to fix this.


#2139

I’m already using the latest expansion patch


#2140

Where are the new patches?
Please tell me the URL.


#2141

This phenomenon does not seem to occur with vanilla.
I think it’s in conflict with some patch.

After resetting on the world map and returning, all units are in the escaped state.
No one was at the party.

As RobertFPY says, I think it is for conflicting with the save data extension patch.
(After all, expanding a class seems unhappy.)


#2142

#2143

thanks.

Does this patch work standalone?
An error was displayed that there is no DebuffTable and DebuffTableSize.

I have to research to get this patch working.


#2144

They are in this:


#2145

thanks.
This routine seems to work fine.

I have to make an update.


#2146

First, please update FEBuilderGBA.

then, In “Class Expansion (2018/05/19)”, press “Update”.

“Class Expansion (2018/05/19)” is removed and “ExModularSave” is installed.

After that, restart the game and it will work without problems.


#2147

Sorry was a bit stressed ive worked on it for pretty long and its gone so i already send a report pretty long ago i hope you did something with it


#2148

It seems that applying the Skills patch screws up the text font when a weapon is broken, making the text hard to read.
emulator

This is how it should look:
Fire%20Emblem%20-%20the%20Sacred%20Stones

It seems that the patch causes different colours to be drawn from the battle-message box palette.
Nothing major, or game-breaking - just aesthetically unpleasing.