FE_Builder_GBA -- If you have any questions, attach report7z

I have watched that video but I skipped around a bit so I might have missed some stuff so I guess I should just go through it again sorry if I’m asking really stupid questions. And sorry for the confusing sentences when I’m writing it makes sense but sometimes even I don’t know what I’ve written. I also type faster then my brains prosses what I’m writing.

Hey, me again. This is a dumb question because I swear I found it the other day but where can I find the animations for arrows, hand axes and javelins and other magic spells? and is it possible to export them to be edited? Thank you.

Motions that units use magic and bows can be changed from “battle animation”.
Bow, magic, magic sword etc are range attacks(indirect attacks), so they are defined in Motion 5, 6.
05=Ranged Animation
06=Ranged Critical Animation

This is the same as attacking with a magcal sword or a spear , bow , magic.
You can change the range animation motion that triggers when attacked from “Magic Animations” of the item.

If you want to create a new magic, apply the additional magic patch and register the image “Magic Animations”.
I think that it is a translation mistake that these are the same name.

In principle, you can not change the flying bow, throwing out, or existing magic effect displayed when you attack.
These are because they are hard coded in the program.

Since these can not be changed, by introducing a magic system patch, you can write it with a script similar to battle animation.

However, for some image data, I know the location.
The throwing spear image data is in the patch.
Magical background data and animation data are found in “Magical animation in ROM”.
However, since these are referenced from the hard-coded code, I think that you can not give detailed instructions.

The safest way is to install a magic system patch and implement it.

If you are interested in the program …
If you want to know the top-level ASM that implements each magic, you can know the address from “Magic Instr Pointers”.
Magic is invoked from this ASM, it seems that each corresponding Procs is created and processed.
Procs is very complicated, but if you are interested, read the STAN documentation.
Also, after connecting to the emulator, pressing the Procs tab allows you to see the data of the currently running Procs.

Ok so the magic animations already in the game cannot be edited because they are hard coded so it is easier to apply the patch and create my own. Thank you very much for the help!

So I started over from scratch and ran into a new, never before seen problem. I created a new map for Chp.15 Scorched Sands and edited the reinforcement coordinates to correspond with the new map. I’ve also created a seizable throne and changed the victory conditions to seize throne. Now when I get to turn 8 and the druid reinforcements appear, the game focuses on Valter and then either freezes or crashes.
There is a link with the problem report.

Pls help.

@7743 is there a way to implement Venno’s array based weapon lock to FEBuilder?
Or is it already implemented?

I do not support it yet.

Currently I am making a very big function, so please wait a while until that is over.
After that, I would like to consider whether I can support it.


Is ch: 15 ?
In the Report 7z received from you, the data contained only ch5 data.
How can I proceed to ch15?

Is ch15 druid about this unit?
I have not advanced the game so far, but I can guess the cause of freezing from this data.

That is because he comes out of the wall.
Please see the location of this unit.
It is in the wall.
With this, he can not move to the designated moving place.
Therefore, it is presumed that the game freezes.(oops! you are in rock)

Okay. That makes a lot of sense. Thank you

Does the Class Relative Power affect exp gain or does it provide a boost for the one with the higher power during a battle between two classes?

Exp gain.

Does “Venno’s array based weapon lock” work?
I tried it with FE8U, but when applying this patch, it freezes when loading the units in the prologue.

Do you know how to make this patch work?

I tested it and it also freezes on the prologue…
To be honest I only used it on FE7, works perfectly there.

Maybe @Venno can help us with this.

I came into an error where the game doesn’t start up naturally but save states work just fine

Hello, is there any way to increase the Limit of deployable NPC (20) in FE7?

To be honest I only used it on FE7, works perfectly there.

I tried it with FE7U, but it also froze when I read the unit in the prologue.
It froze when I read a bandit of enemy unit.

There seems to be a new version and an old version, is it because I am testing with a new version?
In which version are you testing?
Or, could you send me the patch you are using?

Probably it is impossible.
There is a limit to the area that each unit can use.

To remodel this area, extensive remodeling is necessary.
Also, as interruptions are possible, you will need to remodel the save data.

Modification involving saved data is very difficult.

I recommend that you change the specification rather than increasing the NPC.

That’s because you broke the range from 0xA40 to 72 bytes.
You can check it by using the diff debugging tool.

How did you write in this area?

A program of the trunk line part is installed in the region in this neighborhood.
Because you broke it, you can not start it.
Restoring this area to the correct version will start it.

Please start Menu -> Tool -> “Diff Debug Tool” and compare it with the ROM that worked last time.
Then it will detect the difference between 0xA40 and 70 bytes, so please restore it.

For details on how to use specific tools, please read this manual.

I used the new version in my old hack.

I managed to copy the system to a new ROM.
At 0x1634C is the pointer to the item list, then 4 bytes that I don’t really know what they do, but the game crashes if there’s anything than 00490847, and finally the pointer to the ASM dmp is at 0x16354.

The ASM is at 0xDF0500, the table for the indexes is at 0xDF0600, and finally the locks are at 0xDF0B00.

Here’s the patch from a clean ROM with the Lock array system and the modules to edit them in Nightmare.

I hope this can be helpful.