Dancer rings for non-dancers?

I’m looking if there’s a way to have a dancer ring work on a class that can’t use dance/play normally. Is this possible?

1 Like

Yep. I changed Filla’s Might to a Staff and it worked just like that, looks like it’s blacked out in the menu but you can just use it anyway. You could also set it as an item and use it there, but since that uses the unarmed animation you’ll need to set a unique animation for it as well.

1 Like

Speaking from experience, the map animations will also look glitchy if the class using the ring uses different AP data from the dancer and the player has battle animation OFF.

there’s a specific ap that allows map animation dancing for all map sprites

How do you do it by setting it as an item?

Which one is it?

Just that, setting it as an item allows you to use it as you would any item.

I tried that now, but the game softlocks. I tried changing the unit’s AP but it still softlocks. How would I fix it?

By softlocking you wouldn’t happen to mean the screech of death would you.
If you mean when in a battle, that’s due to needing to add a special animation specifically for each of the dancer rings. (Or just change the unarmed animation to something else), if out of battle on the map, then using Nils’ Bard AP from FE7 should rectify that. (it’s probably already in the game but i imported it anyway. welp.)

By softlocking, I mean it erases the UI and the map standing animations and map music keep playing, while the ring user stays immobile. I tried to make the ring a staff, but it didn’t work either. I also set it to map animation only. And I used the Nils AP, but nothing seems to work

I can’t really say what’s happening then, I’ve only really tested this in a clean rom. sorry. ;_;

@Alice are you on FE8 or FE7?

I am in FE8, and I am using Skill Systems

You must make sure to change the “Battle Animation” to FFFE, if you keep the original 3D, it will force battle animations and cause the softlock.

There’s still the issue with classes using AP data other than the dancer’s though. Not sure how to circle around this.

I did exactly that, and it still softlocks. I didn’t get the graphical glitch that you’re showing

You’re absolutely sure you remembered to change its class to item, right? Also, you mentioned that you’re using the Skill System. Did you remember to set the correct IER byte in the item editor?

Yes. Although in this case it’s Ninis’s Grace instead. But everything is set up correctly

I see. Sorry, I don’t think I can help you then…