Can't change units to data-expanded classes

Hello! I’m using FEBuilder and I have a question about changing units’ starting classes. Changing Franz’s starting class to Knight in the Unit Placer works fine, but creating a new class (by expanding the class list) and changing him to that class doesn’t. Once I save my test game and reload the file, he has changed to another class, usually a civilian or a Lord/Great Lord.

I’m sure I just need to change something else to match it, but what? It’s not the starting class in the Character Editor; I’ve done that and it didn’t fix it. It’s not Franz’s class in the Castle Frelia map, either. It’s not even the editor I’m using - I tried doing this with Nightmare and still no dice. Any thoughts?

Thanks in advance!

You need to use the ExModularSave patch if you’re expanding the class list (you should have seen a warning about this?).

Perfect! Worked like a charm!

I did see a warning, but the guide I was using said I could ignore it so I didn’t even read it :sweat: I’ll stick to guides referenced here from now on.

Thanks again, very much!