Battle Animation Issue - Have a look if you don't mind

If you have more skill than I, and you pretty much may have. Look this battle animation, I have no idea why it’s saying it has more than 16 colors, it’s not the first time but I managed to do some fixes before, now I have no idea of what should I do.
If you know the roots of this problem please tell me.
Here it’s the animation:

can you give a useable link

1 Like

Dammm I forgot about this. Let me gimme a second and I will fix it.

Fixed. Thanks for warning me, the file is now a zip file.

Because it has more than 16? Opening up just the first image in my art editor shows this palette:
Screen Shot 2021-12-03 at 4.58.06 PM

1 Like

But the thing I don’t get it is: The same animation in other place with the same amount of colors works fine but the first one just glitchs everything. Here have a look into them in game and in file.

12

imageimage

They are the same, only in different position, yet the first one gets the 16 colors error.
I used the same sprite twice but the first one gets this error and the other not.

Both of these images have more than 16 colours. Have you tried right-click save image as... these images? Might be Discourse messing up their palettes, idk.

1 Like

My mind still does not understand, like. I got the fact that they have more than 16 colors. But why the second one works fine and the other don’t?

Idk, I’d expect neither to work due to being over 16 colours. It’d probably be better if you just reduce both their colours to 16.

1 Like

lul. They have something unholy within them :v, this is the only thing I can think about it. I will try to change some option in the exporting process to see if this could fix it, in the last resort I will decrease their colors.

Why would that be the last resort? Weren’t the original sprites 16 colours?

1 Like

yus, all the sprites I’m using are original from AW2. This pretty much is the last resort because I like to keep the animation the less modified as possible.
HOWEVER, I’m beginning to think that the AW2 has some VRAM involved with it. All vehicles have the no commander variant, so the pallete may be conflicting because in advance wars they were not together and actually some images were just the VRAM.