Amusing ROMhacking Glitches Thread

Tags: #<Tag:0x00007f517ccc3e20>

#555

I have no idea, because I didn’t notice when it first appeared.


Also, I think I created another world-destroying magic spell.


#556

If I do a glitch hack can you make me spells thx


#557




#558


#559

ffs nothing gets posted here for 5 days and right when i post smth it gets ninjaed


#560

Finding maximum map sizing by massive testing:

[This almost works and is a 166x10 map]

[These just don’t work at all but they pretend to work long enough to get screenshots out]

[This is actually the map overwriting part of the map and screwing itself up a bunch]

Minute long gif of non glitchiness showcasing why 120x10 is a horrible map size:
click to watch
Note that the map here actually looks like that so that’s not a glitch

More huge maps causing more “”“interesting”""" results in hunting for the maximum X size for a minimap:

Then I checked the maximum Y size for a functioning minimap

As you can see this loops from the bottom to the top.

60 wide, and 62 tall, are the maximum sizes that the minimap engine handles. Taller than that, however, the minimap engine actually still displays accurately, but the looping annoyance gets worse and worse.

Then, using the formula I had found, I tried a new map size because brute force is good:

4y + 2xy < 3300 (4y = row pointer, 2xy = tile map is 2 bytes per tile)
2y + xy < 1650 (1650 is known to break and 1634 is known to work)
y = 62
124 + 62x < 1650
62x < 1526
x < 24.613
x = 24 ▓▓▓ 2 (62) + (24)(62) = 1612

For some reason the range map wasn’t clearing, dunno why. Didn’t care why, more interested in just finding the actual map sizes one could use.

So far I have that:

2y + xy must no more than evidently 1634, 
[[might be higher]]

x must be no more than 126
the minimap breaks [nonfatally] if x > 60

y must be no more than 91
the minimap connects the top and bottom of the maps if y > 62
the minimap also lets you scroll over-down but this doesn't cause errors

24x by 62y breaks [1612]
24x by 60y doesn't [1560]

#561

idk why you did this when it was discovered like over a decade ago by xeld…


#562

I did this because xeld’s notes were objectively wrong on the matter because they said that columns were more expensive than rows when the exact opposite is the case; they also gave an inaccurate number for the amount of free bytes in RAM for the map (he said it was a little over 3400, for example)

His notes said a 44x44 map should be possible because of this, and those same notes said “but this doesn’t work” or some such, while also having a formula that said that that map size should work

So while, sure, hextator discovered this. He also did it wrong, and thus it might as well not count because it is useless.


#563

Tell me more about how he hurt you, jesus
All I was looking for was “they were wrong”


#564

What happens when you load a class that doesn’t exist? This is what happens. Credit to everybody involved in all resources used in this.

Also… there is Neith, the fusion of Neimi and Seth. Unfortunately they only exist because I can’t debug very well and .bmp isn’t an accepted format.


#565

It’s because “they were wrong” isn’t useful for anyone asking the question of “how big can my map be?”

On topic:





#566


#567

Just like when I first played fe5; because it was in japanese


#568

(-------------------------------)

My life in a nutshell


#569

Now we have Thracia Fog of War and Fog of Info. The true challenge.


#570

i tried to spawn a ballista and this happened

the weird part is neimi can still climb in


#571


#572

I feel like you can’t call that a glitch :confused:


#573

So it worked? I guess…


#574

IT’S A FEATURE

Not the map sprite glitch. The pacifism of my units.
As a last-ditch effort for fixing custom map sprites, I tried setting 20 00 to $24ED4. Accidentally doing it in decimal probably did it.
My custom map sprites are a serious problem though help.

Oh the joy of debugging!