About [CloseEyes]

Sometimes even when there is [CloseEyes] command, the character doesn’t close their eyes. This is something that I kind of just made my peace with that it didn’t work all the time when I was making my hack, but the inconsistency still bothers me. Sometimes a scene plays the way I intended and sometimes it doesn’t without me changing anything in between, so I was wondering if anyone has noticed this and knows why the game sometimes skips the [CloseEyes] command.

At least, the moment you display Portrait, your eyes are not closed.
The reason is that you order to display Portrait and then tell it to close its eyes.
So the moment you issue CloseEye, your eyes are not closed.
There is a time lag of about 1 or 2 seconds for this.

If you want to represent a scene where the unit is sleeping, the easiest way is to prepare a separate Portrait with closed eyes.
I believe this method is also used in vanilla.

The PortaitID can be set up to 2 bytes (0x7FFF), so I don’t think it will run out.
In terms of data size, you can use the same image pointer and just enable the CloseEye setting in the Portrait setting, so there is no need to waste data.

Thanks for the response, but that isn’t really what I was asking about. I was more wondering if there was something like pressing A too many times can cause the game to skip closing a portrait’s eyes because sometimes their eyes don’t close when they’re supposed to.

If this is the case, why don’t you prepare a separate Portrait with closed eyes as explained above and display it again without using CloseEye?
Since the Portrait will be reloaded, the display will disappear for a moment, but it will definitely work.
I don’t think there is any need to stick with unstable instructions.

l think CloseEyes doesn’t work sometimes because the automatic act of blinking gets in the way. Try toggling off blinking a short while before you need to use CloseEyes.

That would make sense since [OpenEyes] and any sort of Toggle command never seems to get skipped. It looks like it’s working so far. Thanks!

I’ve been wondering about this too. What’s the command to toggle blinking?

It’s [DisableBlinking]. There’s a list of all the text commands here. Link

1 Like