32bit Png2Dmp

#1

Good night, sorry to trouble you again everyone. I’m having this problem:

When i tried to write the patch that changes chapters title to text, it sent me this error:

Then, i talked to @7743 and he helped me to get a new event assembler, i tried the new event assembler and still having this problem

Sorry guys, i know you are working in other things, thank you for your time!

Event Assembler
#2

This problem is very strange.
In his environment, Png2Dmp.exe can not run.

The same file can be run in my environment.

It seems that the status does not change even if it is downloaded again.
I do not know the reason.

#3

Is your computer 32 bit or 64 bit? iirc some Event Assembler things have issues on 32 bit computers.

1 Like
#4

yeah, my computer has installed windows 7 Professional 32 bits, so there’s no way to fix it? :c

#5

Give me a second to see if I can compile a version for 32 bits. It’s open source and written in Haskell, so… I should be able to.

Edit: https://stackoverflow.com/a/40023753/1644720
Seems like it’s not so trivial (I’d have to install a 32 bit version of GHC).
Is it possible for you to just send the png file you’re trying to convert, so one of us can run Png2Dmp and you can just #incbin it?

#6
#7

What? you mean the text?

#8

I changed FEBuilderGBA patch from Png2Dmp to incbin.
You can use it after updating.
Now I think that it will work even on 32-bit machines.

1 Like